Support » Plugins and Hacks » [Resolved] [Plugin: Jetpack by WordPress.com] Comments Not Working

[Resolved] [Plugin: Jetpack by WordPress.com] Comments Not Working

  • readers can leave comments but first must register in order to do so. After registering and leaving their comment the post comment button does not work. even if I am logged in as an administrator the post comment button will not work. For an example please visit this page: http://www.fesmediainc.com/stevie-nicks/

    Jetpack has been installed and the Jetpack comments and subscriptions have been configured. Can someone please help me out?

    PS I am a NEWBIE so if code is needed please tell me where to put it.

    Thank you


Viewing 7 replies - 1 through 7 (of 7 total)
  • Update: I disabled requiring readers to register in order to leave comments and once I did that the post comment button worked. So it appears the reason the post comment button will not work is because I am requiring readers to register before being able to leave a comment. Can someone PLEASE help me with this.

    Thank you!

    ok, i hacked together a little work around
    since the button only works if registration is not required, i changed the code so it thinks that registration is never required.
    im not sure about the downstream affects of this are, but it seems to work for me.

    so in this file(you can edit this from your dashboard under Plugins->Editor):
    on line 172
    i commented out this line (by adding two forward slashes):
    'comment_registration' => ( get_option( 'comment_registration' ) ? '1' : '0' ), // Need to explicitly send a '1' or a '0' for these
    and put this below:
    'comment_registration' => '0',

    so basically the modified code in context should look this:

    $params  = array(
    			'blogid'               => Jetpack::get_option( 'id' ),
    			'postid'               => get_the_ID(),
    			//'comment_registration' => ( get_option( 'comment_registration' ) ? '1' : '0' ), // Need to explicitly send a '1' or a '0' for these
    'comment_registration' => '0',
    			'require_name_email'   => ( get_option( 'require_name_email' )   ? '1' : '0' ),
    			'stc_enabled'          => $stc_enabled,
    			'stb_enabled'          => $stb_enabled,
    			'show_avatars'         => ( get_option( 'show_avatars' )         ? '1' : '0' ),
    			'avatar_default'       => get_option( 'avatar_default' ),
    			'greeting'             => get_option( 'highlander_comment_form_prompt', __( 'Leave a Reply', 'jetpack' ) ),
    			'color_scheme'         => get_option( 'jetpack_comment_form_color_scheme', $this->default_color_scheme ),
    			'lang'                 => get_bloginfo( 'language' ),
    			'jetpack_version'      => JETPACK__VERSION,

    users still have to login to comment, but the button works now, at least for me

    Plugin Contributor Tim Moore


    I’m unable to reproduce this issue. Can you send a list of your active plugins and the theme you are using?

    Configurable Tag Cloud
    Custom Admin Bar
    Custom Meta Widget
    Erident Custom Login and Dashboard
    Janrain Engage
    Jetpack by WordPress.com
    Special Recent Posts FREE Edition
    WordPress.com Popular Posts
    WP Export Users Plus
    WP Facebook Open Graph protocol
    WP RSS Images

    i am using a custom theme generated using Artisteer version

    Running WordPress Version 3.4.1

    Plugin Contributor Tim Moore


    Do comments work if you use the Twenty Eleven theme?



    i undid my changes (for the workaround) and everything seems to work fine now

    i did add a few other plugins and updated a few plugins as well as my theme so im not sure what change might have caused/fixed the problem

    i can try to figure out all the changes ive made over the past few weeks if you need, but everything seems to be working fine now (at least for me)

    thanks for your help!

    Jetpack is conflicting with Nivo Slider is there a work around

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] [Plugin: Jetpack by WordPress.com] Comments Not Working’ is closed to new replies.