Jetpack by WordPress.com
[resolved] Adding comment sends me to wp-comments-post.php 404 error (4 posts)

  1. tljohnson
    Posted 3 years ago #

    I've been searching around the forums for this one but nothing has fixed my problem. When someone tries to post a comment on my site, they get redirected to mysite.co.uk/wp-comments-post.php which isn't found. I have tried updating the comments.php script by removing the form tag & contents and replacing it with <?php comment_form(); ?>. This hasn't helped at all. In fact, I don't even think jetpack uses the comments.php script as I've tried inputing test html text within the script and nothing comes up on my page. So I assume there's some code within the iframe which is going wrong here?

    Can anyone help please??


  2. bertbasdf
    Posted 3 years ago #

    Same issue.

  3. Tim Moore
    Plugin Contributor

    Posted 2 years ago #

    Check your WordPress install. In the root of the install, there should be a wp-comments-post.php file. Is there? If there is, check that it has permissions to be run by the web server. If there is not, download a new copy of WordPress from WordPress.org and upload that file.

  4. nigelparrydotnet
    Posted 2 years ago #

    Why is this marked as resolved?

    This 404 Jetpack Comments error only happens for me when Jetpack is connected to WordPress.com. If it is not, the 404 disappears, suggesting some coding error with a relative URL in the last update of the plugin, which was when this broke for me.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Jetpack by WordPress.com
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic