[Plugin: Jetpack] Admin-bar Stats image not showing up (11 posts)

  1. com4
    Posted 4 years ago #

    I'm using Jetpack Version 1.1.3

    My admin bar is displaying a broken image instead of the stats on my site. Clicking the broken image displays the full stats, so I know the plugin is gathering stats. This is a site hosted on Dreamhost. Others I run hosted on dreamhost do not have this problem.

    Here is a screenshot of the bar: http://i.imgur.com/Zl70z.png

    There are no htaccess files in the wp-admin directory, the plugin directory, jetpack, or modules. The only htaccess file is in the root which just contains the rewrite rules. I've deleted and reinstalled the plugin. Everything is up-to-date.

    Lastly, I'm using the BusyBee template and my other installed plugins are:

    • akismet 2.5.3
    • disqus comment system 2.67
    • Googlyzer 1.2.1
    • MediaElement.js 2.2.5
    • wordpress amazon associate 1.7.4
    • WordPress SEO 1.0.3

    How do I fix, or troubleshoot this problem further?


    p.s. for the more technically inclined: when I download the image it's not an empty file, it's just a corrupt png. (Saved with File->Save As on the image url):

    texbook:~ jason$ ls -la Desktop/admin.png
    -rw-r--r--@ 1 jason  staff  204 Oct 29 11:25 Desktop/admin.png
    texbook:~ jason$ cat Desktop/admin.png 
    ?texbook:~ jason$
  2. Ahlforn
    Posted 4 years ago #

    I have the exact same problem after I moved my site to a new host. I haven't been able to trace the problem, so I'm hoping someone know how to fix this.

  3. pbassham
    Posted 3 years ago #

    Anyone figure this out? Im having the issue after moving to a new host (dreamhost)

  4. com4
    Posted 3 years ago #

    FWIW, I havent. It's still broken.

  5. d33k
    Posted 3 years ago #

    I'm having the same issue after migrating to a new host as well, just like @pbassham mentioned. Would like to see a resolve to this.

  6. wwwebconcepts
    Posted 3 years ago #

    Same issue and I run my server and just installed jet pack. Dooes any know the image file name?

  7. bobbingwide
    Posted 3 years ago #

    Having had the same problem for a few weeks now I analysed this problem today and applied a patch to my local copy of Jetpack along the lines proposed in

    I changed some code in module/stats.php (function stats_report_page() )
    die( $get['body'] );


    $img = $get['body'];
    header( 'Content-Length: ' . strlen( $img ) );
    echo $img;

    This has resolved the problem me.
    I will attempt to make a patch for Jetpack version 1.7 available.

  8. bobbingwide
    Posted 3 years ago #

  9. martinremy
    Posted 3 years ago #

    Thanks for the patch @bobbingwide! Committed and will be in the next Jetpack update.

  10. Emma_W
    Posted 3 years ago #

    I'm having the same problem. Used bobbingwide's patch and it's still not working. :/ Not sure what the next step should be...

  11. wwwebconcepts
    Posted 3 years ago #

    I have the same issue in all browser, IE, Chrome, FireFox, Opera. But when I select show image in new tab in Chrome I still get broken image. Would some be kind enough to tell me the image filename?

Topic Closed

This topic has been closed to new replies.

About this Topic