[Plugin: Jetpack 1.1.3] register_http_request_failed (5 posts)

  1. jhurlbut
    Posted 4 years ago #

    Hi there, I'm fairly new to WordPress, but not to blogging. I have 3.2.1 installed at: http://ilovepiercecounty.com/ and wanted to add some of the WordPress.com functionality to my blog and installed the Jetpack plugin. The Plugin installed apparently, but when I push the "Connect to WordPress.com" button, I get the following error:

    Jetpack could not contact WordPress.com: register_http_request_failed.

    This usually means something is incorrectly configured on your web host.

    There are no HTTP transports available which can complete the requested request.

    I've found on the forums that a number of people are having the same issue. Some get it resolved, some don't. I e-mailed my hosting provider (Jodohost) and they say they can't help me with WordPress, but if something needs to be changed on the server to let them know and they'll work on it. I have no idea of what might need to be changed.

    I've also sent a request to support@wordpress.org and have yet to hear back.

    Has anyone figured out a way to troubleshoot this issue to understand exactly why this is coming up? I've seen a number of theories about changing timeout values, etc.

    If anyone could point me in the correct direction, I'd REALLY appreciate it.


  2. pgoly
    Posted 4 years ago #

    install core control plugin, go to external HTTP access and disable cURL. then try to connect WP from jetpack.

  3. Paul
    Posted 4 years ago #

    That worked for me!

  4. evilforces
    Posted 3 years ago #

    Worked for me too!!! thanks!!!!

  5. abtech
    Posted 3 years ago #

    If you manage your web server and set the outgoing connections to allow the IP address then you should have no issues. After you set it wait about a half an hour though.

Topic Closed

This topic has been closed to new replies.

About this Topic