[Plugin: IWantOneButton] Some problem (2 posts)

  1. Marcomail
    Posted 6 years ago #

    The url for vote it's wrong, the permalink is duplicated.

    if you add "<!--havewantbutton-->" in the visual editor the plugin don't work, you must add it in the html editor.

    could be good have various design to choose, and use ajax for voting :)



  2. DanielSands
    Posted 6 years ago #

    Hi Marcomail.
    The permalink for the vote is just pointing to the post, using the get_permalink() function, then simply adding a "add=want&id=postid" query string to the end, which is picked up when the link is clicked. If this link is pointing somewhere wrong I advise that you check the permalink settings on your WordPress installation, and check that "get_permalink()" will return the correct link to the post.

    Ah, regarding the use in a visual editor - that is an oversight, as this is the very first release - it was something that was overlooked, I may look into having a tick box on the New/Edit posts screen instead.

    It would be a great idea to have different designs, and this is something I will be looking to implement shortly, again - with this being a first release I just want to check that all coding is correct, and people can install without any issues before developing the code any further.

    AJAX is a great idea, again this will be included in upcoming versions.

    Thanks for your feedback, it's greatly appreciated.

Topic Closed

This topic has been closed to new replies.

About this Topic