Support » Plugins » [Plugin: iThemes Security and WP-Piwik] iThemes blocks connections

  • First iThemes Security caused problems with SEO by Yoast, by not showing the sitemaps. Disabling iThemes and enable it again solved this. But now I discovered that WP-Piwik gets 403 and 500 errors. Disabling iThemes and it works fine. Perhaps does anyone know which feature of iThemes I can disable?

    Below the WP-Piwik test script result:

    *** Test 1/2: SitesManager.getSitesWithAtLeastViewAccess ***
    Using: cURL
    SSL peer verification: enabled
    User Agent:
    Call: https://www.hotelsandproperties.com/pw/?module=API&method=SitesManager.getSitesWithAtLeastViewAccess&format=XML&token_auth= + TOKEN
    Result:
    HTTP/1.1 403 Forbidden
    Date: Thu, 31 Jul 2014 17:43:09 GMT
    Server: Apache/2.2.26 (Unix) mod_ssl/2.2.26 OpenSSL/1.0.1e-fips mod_bwlimited/1.4 mod_qos/10.10
    Content-Length: 495
    Connection: close
    Content-Type: text/html; charset=iso-8859-1

    <!DOCTYPE HTML PUBLIC “-//IETF//DTD HTML 2.0//EN”>
    <html><head>
    <title>403 Forbidden</title>
    </head><body>
    <h1>Forbidden</h1>
    <p>You don’t have permission to access /pw/
    on this server.</p>
    <p>Additionally, a 500 Internal Server Error
    error was encountered while trying to use an ErrorDocument to handle the request.</p>
    <hr>
    <address>Apache/2.2.26 (Unix) mod_ssl/2.2.26 OpenSSL/1.0.1e-fips mod_bwlimited/1.4 mod_qos/10.10 Server at http://www.hotelsandproperties.com Port 443</address>
    </body></html>

    Time: 0.02s

    *** Test 2/2: SitesManager.getSitesIdFromSiteUrl ***
    Using: cURL
    SSL peer verification: enabled
    User Agent:
    Call: https://www.hotelsandproperties.com/pw/?module=API&method=SitesManager.getSitesIdFromSiteUrl&url=https%3A%2F%2Fwww.hotelsandproperties.com&format=XML&token_auth= + TOKEN
    Result:
    HTTP/1.1 403 Forbidden
    Date: Thu, 31 Jul 2014 17:43:09 GMT
    Server: Apache/2.2.26 (Unix) mod_ssl/2.2.26 OpenSSL/1.0.1e-fips mod_bwlimited/1.4 mod_qos/10.10
    Content-Length: 495
    Connection: close
    Content-Type: text/html; charset=iso-8859-1

    <!DOCTYPE HTML PUBLIC “-//IETF//DTD HTML 2.0//EN”>
    <html><head>
    <title>403 Forbidden</title>
    </head><body>
    <h1>Forbidden</h1>
    <p>You don’t have permission to access /pw/
    on this server.</p>
    <p>Additionally, a 500 Internal Server Error
    error was encountered while trying to use an ErrorDocument to handle the request.</p>
    <hr>
    <address>Apache/2.2.26 (Unix) mod_ssl/2.2.26 OpenSSL/1.0.1e-fips mod_bwlimited/1.4 mod_qos/10.10 Server at http://www.hotelsandproperties.com Port 443</address>
    </body></html>

    Time: 0.03s

Viewing 2 replies - 1 through 2 (of 2 total)
  • Found it! iThemes Security 4.3.7 blocks again the wp-admin/admin-ajax.php. It did before and they make a fix to solve the issue.

    I hope they will fix it soon. The bulk optimize from EWWW Image Optimizer is also blocked for the same reason. It’s annoying..

    Try deactivating “Filter Suspicious Query Strings in the URL”.

    Regards. 🙂

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Plugin: iThemes Security and WP-Piwik] iThemes blocks connections’ is closed to new replies.