WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Plugin issues with WP 3.5

[Resolved] Plugin issues with WP 3.5

  • This plugin generates a large number of PHP undefined index and undefined variable issues with WP 3.5 running in debug mode. It’s unclear whether the plugin works as expected because I’ve been reluctant to put it to use with so many PHP notices (no PHP warnings or other errors are being generated that I can see).

    1) Activating the plugin generates several thousand characters of unexpected output

    Then, User Meta Manager admin screen:

    2) Generates several PHP notices when working in WP debug mode:
    – undefined index: per_page in includes/umm-table.php
    – undefined variable: extra_fields in includes/umm-table.php
    – undefined index: orderby in includes/umm-table.php
    – undefined index: order in includes/umm-table.php
    – undefined index: s in includes/umm-table.php
    – undefined index: umm_search_mode in includes/wmm-table.php

    3) Undefined index: umm_search_mode in the “Home” tab in umm-table.php

    4) Large number of undefined variable notices in the “Add Custom Meta” tab in user-meta-manager.php (vars: $type, $label, $class, $attrs, $required, $add_to_profile)

    http://wordpress.org/extend/plugins/user-meta-manager/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author President McCheese

    @jason-lau

    “no PHP warnings or other errors are being generated that I can see”

    Undefined variables aren’t critical, which is why these are notices and not warnings or errors. This does not affect the functionality of the plugin or WordPress.

    However, since you mentioned it, I will try to clear them up.

    Thanks for the input.

    Plugin Author President McCheese

    @jason-lau

    Version 2.0.7 cleans all of the PHP notices, which were the unexpected output you referred to.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] Plugin issues with WP 3.5’ is closed to new replies.