Support » Plugin: RSS Footer » Plugin is Now Broken

  • I know Yoast wants people to use their SEO plugin, but I’m not a fan. This plugin still works if you use version 0.9.8, so install that and don’t update it. While the current version warns of security issues, this is simply a PHP call to add the post link to the output. What security issues could there be?

    https://wordpress.org/plugins/rss-footer/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Yea, don’t update if you still want it to work.

    Shame Joost has done this.

    I hope someone takes over this plugin and maintains it for future usage.

    Please list alternative plugins below.

    Thread Starter Brad West

    (@bradawest)

    I’m just going to add this manually to my functions file. You can do the same if you like:

    add_filter( 'the_content', 'embed_rssfooter' );
    add_filter( 'the_excerpt_rss', 'embed_rssfooter' );
    function embed_rssfooter($content) {
      if ( is_feed() ) {
        $content .= '<p><a href="' . get_permalink() . '">' . get_the_title() . '</a> was originally published on <a href="' . get_bloginfo('url') . '">' . get_bloginfo( 'name' ) . '</a></p>';
      }
      return $content;
    }

    Otherwise there’s John Saddington’s plugin TentBlogger Add RSS Footer. It hasn’t been updated in a while which probably scares people, but in this case there’s little to update.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Plugin is Now Broken’ is closed to new replies.