Support » Plugin: Freesoul Deactivate Plugins » Plugin is not working my Site

  • Resolved Bradock

    (@valberfigueiredo)


    Friend I met your plugin recently and what he proposes to do is incredible both in analyzing the problems of others and in helping to speed up the website by disabling plugins in unnecessary places to be executed.

    But I still can’t use it, I have a problem.

    When activating and configuring option> Single> in the plugin settings and trying to save.

    The plugin cannot save is looped for a few seconds and takes my site down and I get a warning below or just is infinite loop and never saves settings.

    Image: https://ibb.co/tYHZgHV

    Message basically says that: There was an error establishing a database connection / Warning that the database is down …

    Ai to return I access FTP rename plugin.

    And restart server and site back to normal.

    I rename the plugin again via FTP to the name Orginal nomavente and when activating the plugin again I get this other warning:

    Image: https://ibb.co/gDX0Lvh

    Translation Image: The plugin generated 98 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with feeds or other problems, try to disable or remove this plugin.

    I am using Perfmatters Plugin with option> Scripts Manager> Enabled.

    Here link about: https://perfmatters.io/docs/disable-scripts-per-post-page/

    Here 2 configurations with perfmattrs for example:

    https://ibb.co/MhqYjkM

    Could this be hurting too?

    Please, can you help me.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Jose

    (@giuse)

    hi @valberfigueiredo
    thank you for opening a thread and for your nice words about the plugin, now let’s try to make it work 🙂

    The first error is related to the database connection. This usually happens when the database username or password that are written in wp-config.php are wrong, or when the database server is down.

    When you save the “Single” options, Freesoul Deactivate Plugins calls the database because it wants to save the options. I will speak more about this issue later.

    About the second error “The plugin generated 98 characters of unexpected output” I quickly tell you how FDP works. When you activate FDP, it writes a mu-plugin in the folder wp-content/mu-plugin. This file runs before any other plugin.
    When you deactivate FDP, it deletes that mu-plugin.
    In your case, you have disabled FDP via FTP, so the mu-plugin was still there. When you reactivated FDP, because the file was already there, the PHP parser triggered a warning (something like “the file already exists…”. Because this warning, activating FDP, the parser PHP interpreted that warning as a text to send through the header, but because at that point WordPress had already sent the headers, it triggered the warning “The plugin generated 98 characters of unexpected output…”.

    You don’t have to worry about the second error. Disabling FDP via FTP and activating it again, it’s normal to have a warning.

    I would focus on the first error related to the database connection.

    In my opinion, the most probable cause is that your database server was down during the saving process.

    I have a couple of questions:
    – how many plugins do you have?
    – does it happen every time you save the Single options, or sometimes yes and sometimes not?
    – have you already had a database connection error in other situations?
    – do you know the database size?
    – does it happen also saving other FDP options (e.g. “Post Types”)?

    If you confirm that it happens only when FDP is active and only during the “Singles” saving process, I ask you to do the following to test with less load:

    1 Activate again FDP
    2 Go again to the “Singles” settings
    3 Put 5 in the field “Number of posts” and then press apply. You will have only 5 rows
    4 Save options
    5 Change some settings
    6 Save options

    If the database server doesn’t go down, repeat the points from 3 to 6 with a higher number of posts.

    Regarding Perfmatters, I don’t know. I’ve never tested FDP with Perfmatters.
    However, I don’t think it’s a conflict with Perfmatters, unless Perfmatters adds work when saving Singles options.
    If you want to be sure, you can disable Perfmatters, try again to save the FDP “Singles” options and see if it works. But I would do this after checking the points above.

    Bradock

    (@valberfigueiredo)

    You asked:

    – how many plugins do you have? Active 30

    – does this happen every time you save the Single options, or sometimes yes and sometimes no?
    Yes, every time when trying to save settings in the Single and Homepage options

    – Have you ever had a connection error with the database in other situations?
    Yes, a while ago. But it had not happened for a long time. It seems that plugin overloads and database crashes.

    And it is only happening with FDP plugin if you activate other plugins and configure it does not happen.

    – do you know the size of the database?
    No

    – does this also save other FDP options (for example, “Post types”)?

    Option> Post types> works perfectly and saves the settings made very quickly.

    I only encounter problems with Single and Homepage options.

    ==========================

    When trying to make settings:

    1 Activate FDP again
    2 Go back to the “Singles” settings
    3 Put 5 in the “Number of posts” field and press Apply. You will only have 5 lines
    4 Save options
    5 Change some settings
    6 Save options

    When the Perfmatters plugin was active, I put 5 in the “Number of posts” field and hit Apply and was unable to save the loop and then the website crashed.

    So I deactivated the Perfmatters Plugin and put 5 in the “Number of posts” field and clicked save.

    And then this time I managed to save.

    But when configuring Single or Homepage options and trying to save, there was still a problem getting infinite loop or website crashes.

    Plugin Author Jose

    (@giuse)

    thank you very much @valberfigueiredo

    It looks FDP + Perfmatters together give too much load to the database server.

    Probably Perfmatters hooks to the saving process and does something.

    I’m already working to improve the performance during the saving process.
    I think I have some margin for improvement.
    The goal is that you can save with at least 30 posts + Perfmatters active.

    I will inform you as soon as I can release a new version including the fix for this issue. I suppose in a couple of days it is ready, but I can’t promise it.

    Plugin Author Jose

    (@giuse)

    @valberfigueiredo

    I see now you wrote you have issues also with the Homepage settings.
    There FDP doesn’t load the database.

    I kindly ask you to save the Singles settings after disabling Perfmatters with 30 posts instead of 5.

    In any case, I will improve the performance during the Singles options saving process.
    But for me, it’s important to know if without Perfmatters the saving process is successful with at least 30 posts.

    If you can save with 30 posts without Perfmatters, it will be not enough to improve the FDP performance during the Singles saving process, I will need also to understand what Perfmatters is doing during the process. Because even having very good performance, the load will not be lower than saving the Homepage settings.

    Please let me know what happens after saving the options with 30 posts without Perfmatters.

    • This reply was modified 6 months, 3 weeks ago by Jose.
    • This reply was modified 6 months, 3 weeks ago by Jose.
    Plugin Author Jose

    (@giuse)

    Hi @valberfigueiredo as you have written in your email, the issue is solved.
    I will close the thread. If you find new issues, don’t hesitate to open a new thread.

    Thank you very much for discovering this problem.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Plugin is not working my Site’ is closed to new replies.