Support » Plugin: Jetpack Holiday Snow Opt-In » plugin is not working

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Josh Eaton

    (@jjeaton)

    Hi @vl4d, can you give me some more information on what’s not working for you? I’d be happy to re-test it on latest WordPress but knowing your issue will help me track it down. Thanks!

    the snow icon from plugin photos is not show up (i don’t have any errors) so maybe is the wp version the problem..

    (my theme is true mag)

    I tested this and found the plugin to work on my site. However the button was partially obscured by the black border on my theme. I used CSS to place the div of the button on a higher level:

    #jetpack-holiday-snow-opt-in {
    	z-index: 100;
    }

    The default CSS places the snowflake button at the top of the window, just a bit over from the right side:

    Snowflake

    i put the css code but again the snow icon is not show up (i tested with white and black background)

    Plugin Author Josh Eaton

    (@jjeaton)

    Hi vl4d,

    I’ve just released v0.1.4 which should fix your issue. Please update and let me know whether it’s resolved. Thanks!

    the same :/ not working, check the site test

    Plugin Author Josh Eaton

    (@jjeaton)

    @vl4d do you have the plugin active? It does not appear to be loading at all. It wouldn’t load if you disable it, or disable jetpack, or don’t have the snow option enabled on the General Settings page.

    so i disable the snow from jetpack and now i don’t have snow and the button 🙂

    Plugin Author Josh Eaton

    (@jjeaton)

    Snow needs to be enabled, but do you have my plugin installed and active?

    Plugin Author Josh Eaton

    (@jjeaton)

    That’s odd.

    Can you switch to the twenty sixteen theme and verify that it still doesn’t work when that is active?

    I don’t have your theme to test but it may be something in the theme or in one of the other plugins that is blocking this one from loading.

    Plugin Author Josh Eaton

    (@jjeaton)

    Also if you have any page caching plugins clear the cache first as that would prevent it from loading

    i try new theme pause from cloudflare nothing anyway will create a new button ?show_snow=1 and will be ok (thanks for help )

    • This reply was modified 2 years, 11 months ago by  vl4d.
    Plugin Author Josh Eaton

    (@jjeaton)

    @vl4d, CloudFlare is likely the issue. The way the plugin is currently built, it doesn’t work with full page caching. I have planned a 0.2.0 release that will rewrite this plugin completely to support full page caching, but at this time I can’t provide a timeline for its release, as it will be a complete rewrite of the plugin.

    Even creating a custom button, it likely won’t work correctly if the rest of the plugin isn’t loading. Sorry for the inconvenience.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘plugin is not working’ is closed to new replies.