Support » Plugin: Amazon Associates Link Builder » Plugin is not linking posts to Amazon.com

  • Resolved phillengel

    (@phillengel)


    I’m having an issue with the plugin not linking my products to the Amazon store. The theme combined with the plugin on my website https://www.yellowfashion.store allows for the thumbnail and the “Check it out button” to link to the pictured product on Amazon.com, and give the product price on my website.

    However, ever since I started receiving the error: You are submitting requests too quickly. Please retry your requests at a slower rate. For more information, see Efficiency Guidelines.

    I don’t add the product shortcode, and my website only receives 1000 page views per day. I just use the Amazon plugin feature above the publish box when adding new posts. Since the error popped up, the plugin does not link my thumbnails to the Amazon store or show the price though. What would be a good fix for this?

    Thanks,
    Phil

    • This topic was modified 2 years, 2 months ago by phillengel.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • I have exactly the same problem. I think it is the new update of the Plugin, because that’s when the glitch started. I even uninstalled and reinstalled the plugin to see if it works. It didn’t.

    I have now sent a support request to Amazon Associates and will see what the outcome is. Maybe you can do the same? I will however post their response when I get it.

    Plugin Author Amazon Associates Link Builder

    (@amazonlinkbuilder)

    Dear @phillengel & @kimbock,

    The error: “You are submitting requests too quickly” is due to throttling. This has to do nothing with this plugin update. Please check if you allowed request count has reduced for any reason. You can write to Product Advertising API by filling form at https://affiliate-program.amazon.com/home/contact/ and select Product Advertising API from the subject.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Plugin is not linking posts to Amazon.com’ is closed to new replies.