Support » Plugin: Magic WP Coupons - Lite » plugin is not compatible to the latest version of wordpress

Viewing 4 replies - 1 through 4 (of 4 total)
  • If you are having the same issue as me, this is caused by the fact that get_currentuserinfo() is deprecated in 4.5 and has been moved to pluggable-deprecated.php

    The fix is to edit admin/includes/data_options.php

    Need to change:

    if ( !function_exists('wp_get_current_user') ) {
    require_once (ABSPATH . WPINC . '/pluggable.php');
    }

    to:

    if ( !function_exists('wp_get_current_user') ) {
    require_once (ABSPATH . WPINC . '/pluggable-deprecated.php');
    }

    I just commented out this line get_currentuserinfo(); line in admin/includes/data_options.php like this:

    //get_currentuserinfo();

    I’m not sure what that’s used for but hopefully plugin author will fix it. Also what Roberto Villerreal wrote didn’t fix mine, I still got various auth and cookie errors. plus it sounds like that function is deprecated so the plugin will need to be fixed not to use any deprecated elements.

    Plugin Author shahzad11

    (@shahzad11)

    Thank you guys for that precious sharing. We have launched Magic WP Coupons 3.0. That issue is fixed in that new version.

    This new version has a bunch of issues in the admin section. It even screws up adding new posts, I simply cannot add any new posts until I disable the plugin. If I try to save a post, it just deletes all content and saves an empty post.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘plugin is not compatible to the latest version of wordpress’ is closed to new replies.