Support » Plugin: WordPress Social Sharing Plugin - Sassy Social Share » Plugin is loading on home page

  • Resolved ranajittelugu


    Hello developers,
    First of all Thanks for your plugin. I really love the buttons of this plugin, but now I’m getting one issue. When I load my website home page( front page ) I saw in developers tools that plugin is loading some JS and CSS file in home page. And also when I checked my speed in google page insight ( )then I am sure about this. Please help me, because I don’t want to load on my home page of website. I need it only for inside article page ( post page )not any other pages. Please help me how to stop or disable the load in my home page I have mentioned the URL of my website also.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Heateor Support


    Hi there,

    Sorry about the late reply. Didn’t get email notification for this thread.
    You can control the placement of icons from Standard Interface and/or Floating Interface section(s). To remove the icons from homepage disable Homepage and Excerpts and Posts page page groups in Placement option.

    Hey, I would be second to that. The plugin is fine, thanks.
    But the way you use wp_enqueue_script(style) is NOT OK.
    Inline code and scripts load on all pages regardless of Placement options selected. Most awful ugly inline code is in the upper part of header.
    And in our case (we use shortcode on special pages) that is pita – we need to manually hack and deregister your scripts/styes.
    Please reconsider.

    Plugin Author Heateor Support


    @unostar For now you have to dequeue the scripts, CSS manually. Will take care of it in upcoming releases.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Plugin is loading on home page’ is closed to new replies.