WordPress.org

Forums

WP Super Cache
Plugin is caching logged-in state (8 posts)

  1. publicradio
    Member
    Posted 11 months ago #

    Hi,

    For some reason, WP Super Cache is caching when my client is logged in. I haven't had this problem with my log in, but a couple times now I have gone to the site and the admin bar is showing, and it says I'm logged in as my client. I am not actually logged in as her, however, as it is just a static, cached page.

    When I clear the cache, the site goes back to normal. Why is WP Super Cache caching a logged-in state? How do I prevent this?

    https://wordpress.org/plugins/wp-super-cache/

  2. Brandon Kraft
    Happiness Engineer
    Plugin Author

    Posted 11 months ago #

    That shouldn't be happening at all. Does this happen with all other plugins disabled?

    Can you activate the debugging tool via the Debug menu and attempt to duplicate the issue (have WP Super Cache cache the user while logged in, and then hit the cached version)? The debugging information would tell us quite a bit.

    Cheers!

  3. publicradio
    Member
    Posted 11 months ago #

    OK, I can't disable all plugins, but I disabled some: Better WP Minify, Theme Test Drive --- But I had to leave a couple, like Jetpack.

    I enabled debugging and I will let you know what I find.

  4. publicradio
    Member
    Posted 11 months ago #

    Hi Brandon, I am back with some debugging info. The Problem is still happening, and when I tested the cache I got:

    The pages do not match! Timestamps differ or were not found!

    And here is the log. I can't make heads or tails of this, but I bet it makes sense to you.

    Thanks so much!

  5. Brandon Kraft
    Happiness Engineer
    Plugin Author

    Posted 11 months ago #

    Thanks for the info. It's a bit to go through :) but we're on it.

  6. Donncha O Caoimh
    Member
    Plugin Author

    Posted 11 months ago #

    There's something really odd about your install. That debug log should mention "wp_cache_get_cookies_values" where it detects that the user is logged in.

    Are you using different auth cookies?

    Have you tried "Don’t cache pages for known users" on the Advanced settings page of the plugin to fix this?

  7. Donncha O Caoimh
    Member
    Plugin Author

    Posted 11 months ago #

    Oh, get rid of your debug log, it reveals a lot about your webserver that shouldn't be public ..

  8. publicradio
    Member
    Posted 11 months ago #

    Thanks Donnacha, I deleted the log. I have checked 'Don’t cache pages for known users' so we'll see if that makes a difference.

    I have a section in wp-config for unique keys and salts, but these lines were auto-generated and I've never changed them.

Reply

You must log in to post.

About this Plugin

  • WP Super Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags