Support » Plugin: BBQ Firewall » Plugin is blocking all requests from Google bots

  • Resolved cybergirl

    (@cybergirl)


    I don’t know why, but this Plugin is blocking all requests from Google bots.
    If bing bot is making same request I can see on logs http 200 answer. Google bots gets 403. I’ve checked IP range is not blacklisted on whole server or site settings.

    Ex. for requests:
    66.249.66.132 – – [03/Jul/2019:07:42:34 +0200] “GET /wp-content/cache/fvm/1556715246/out/header-2e754fa1.min.css HTTP/1.1” 403 5037
    66.249.66.130 – – [03/Jul/2019:07:42:35 +0200] “GET /wp-content/cache/fvm/1556715246/out/header-565a0828.min.js HTTP/1.1” 403 5036
    66.249.66.134 – – [03/Jul/2019:07:42:35 +0200] “GET /wp-content/cache/fvm/1556715246/out/header-3de319b6.min.js HTTP/1.1” 403 5036
    66.249.66.130 – – [03/Jul/2019:07:42:36 +0200] “GET /wp-content/cache/fvm/1556715246/out/footer-89971e65.min.js HTTP/1.1” 403 711
    66.249.66.134 – – [03/Jul/2019:07:42:36 +0200] “GET /wp-content/cache/fvm/1556715246/out/footer-9be42755.min.js HTTP/1.1” 403

    Same requests bing.
    207.46.13.215 – – [03/Jul/2019:01:18:24 +0200] “GET /wp-content/cache/fvm/1561462183/out/header-565a0828.min.js HTTP/1.1” 200 5779 “-” “Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)”
    157.55.39.114 – – [03/Jul/2019:01:18:29 +0200] “GET /wp-content/cache/fvm/1561462183/out/header-bd7a4319.min.css HTTP/1.1” 200 40029 “-” “Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)”
    157.55.39.114 – – [03/Jul/2019:01:18:29 +0200] “GET /wp-content/cache
    /fvm/1561462183/out/footer-9be42755.min.js HTTP/1.1” 200 55506 “-” “Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)”

    The only diff. between both is the agent, which for Google is “Mozilla/5.0 AppleWebKit/537.36 (KHTML, like Gecko; compatible; Googlebot/2.1; +http://www.google.com/bot.html) Safari/537.36”

    After disabling the plugin Google bots are not blocked anymore:

    66.249.66.130 – – [03/Jul/2019:09:48:24 +0200] “GET /wp-content/cache/fvm/1561886203/out/header-3de319b6.min.js HTTP/1.1” 200 46601
    66.249.66.130 – – [03/Jul/2019:09:48:24 +0200] “GET /wp-content/cache/fvm/1561886203/out/header-565a0828.min.js HTTP/1.1” 200 1454
    66.249.66.130 – – [03/Jul/2019:09:48:25 +0200] “GET /wp-content/cache/fvm/1561886203/out/header-bd7a4319.min.css HTTP/1.1” 200 35704
    66.249.66.130 – – [03/Jul/2019:09:48:25 +0200] “GET /wp-content/cache/fvm/1561886203/out/footer-9be42755.min.js HTTP/1.1” 200 55506

    How to fix this ? In use php 7.0, WP 5.2.2

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Jeff Starr

    (@specialk)

    Glad to help. I’m not sure what is blocking those requests, but can tell you that it is not BBQ. Why? Because BBQ firewall works by matching each request against a set of known malicious strings. Only if there is a match is the request blocked. And none of those requests match any of the BBQ patterns. So again not sure what is happening, but the it’s not something that BBQ is doing.

    OK. But as you can see it must be something with BBQ, cause when I disable the module the same request are not blocked also for Google Bots. The only diff. between bing request and google request is the agent user.

    • This reply was modified 1 year, 6 months ago by cybergirl.
    Plugin Author Jeff Starr

    (@specialk)

    There must be a another factor involved, because there is no way for BBQ (by itself) to block the requests you mention; it’s just not possible. So it could be that another plugin is interfering only when BBQ is active, such that the requests are blocked. Examples of possible plugins that may interfere including things like caching plugins, security plugins, and/or any plugins involved with HTTP requests. That would be the first place to start investigating.

    • This reply was modified 1 year, 6 months ago by Jeff Starr. Reason: add info
    Plugin Author Jeff Starr

    (@specialk)

    @cybergirl do you still need help with this? It’s been a couple of weeks with no response, so gonna go ahead and mark as resolved to help keep things organized. Feel free to post again with any new questions, feedback, etc. Glad to help however possible. Thank you.

    Yes and no. I cannot identify what exactly is blocking and what not. I have several firewalls working together. Disabled also wp caching module. It solved for one day, on the next same problem again with module disabled. Seems to be a working together causing false/positives… Difficult to identify which one is causing the problem.

    Plugin Author Jeff Starr

    (@specialk)

    Understood. Let me know if I can provide any infos about BBQ, glad to help however possible.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Plugin is blocking all requests from Google bots’ is closed to new replies.