Support » Plugin: iQ Block Country » [Plugin: iQ Block Country] Not Downloading

Viewing 7 replies - 1 through 7 (of 7 total)
  • On the FAQ page there is a link to download the latest database file:

    Here is the actual link:

    Place the unzipped GeoIP.dat file in the root of the iq-block-country folder.

    Thank you for that information – I’ll pass it on to others who had a similar topic on this.

    Best Wishes,



    Well I followed these instructions and the upload failed. Repeat and rinse, same result.

    I’m not sure if I wish to spend any more time on this. The original geoip file was readable in notepad, the new geoip file (date.file) is not.

    The this is a dat file vs. a txt file? Is this the problem with the upload to the server files? Not sure.

    One thing I am noticing is the zip file is downloading to my hard drive as a “gz” and not showing up in the download file up I attempt to upload to the server and extract from there.

    I extracted with a unzip tool and upload the dat file and that’s when I received the upload error.

    @ Don, I’m not sure what you’re doing, but I don’t have any problem with it. I download the GeoIP.dat.gz file to my desktop. Then with a utility like 7zip I unzip it to my desktop to have the GeoIP.dat file. Then I FTP/SFTP the GeoIP.dat file to the iq-block-country folder.

    Hi Mickey:

    Some days I’m not sure what I’m doing either. 😉

    Although I’m getting a “failed” response after downloading/uploading the dat file to the server the file still appears in the folder. Go figure.

    Now, this morning I went through the exercise in my WP admin, hit the download button “Download New GEO IP Database” and it worked. No error message.

    Pascal mentions in his FAQ notes the GEOIP Lite may only allow a certain number of downloads from servers in a 24 hour period as follows:

    Why does downloading the GeoIP.dat.gz fail?

    For instance Maxmind limits the number of downloads per day. They probably do this by IP address so if you or somebody else who has a site at the same server your site is running on already downloaded the new database you may be blocked for 24 hours by MaxMind. No worries try a day later again.

    So something having to do with download excess may have been the problem with my host. I had the problem with the first download so it wasn’t too many downloads on my side, except after attempting to make it work several times.

    So waiting over night seems to have worked. Now the question – I have a number of sites on the same server. Will this problem occur again? If it does than implementing the fresh database to this plugin on multiple sites may take many days.

    Regardless, the problem must have been related to Pascal’s post on downloads.

    Thanks for your help, it’s appreciated.

    @ Don,

    I’m not sure what’s going on with downloading it via the plugin. There were issues in the past, and I just downloaded it straight from the source just to be on the safe side. There probably are limitations to the download. Like the limitations that Stop Forum Spam has on downloading their database. I guess everyone needs to control their traffic/bandwidth one way or another.

    Good luck.

    In reference to Pascal’s FAQ notes I posted above:

    Today I went through my first six sites and on that last one I received the error message. So I’ll return tomorrow to update.

    There isn’t a problem to at least have the plugin installed and working regardless prior to updating the database file.

    It’s been my experience that new IPs sometimes only add a few new ones over a period of time.

    i.e. I had to block the entire range for Amazon’s cloud on a site on it’s own server to block a hacker. They are in the US so I can’t use the IP Block Country plugin. Amazon has updates or adds new IPs but it hasn’t been a lot at any one time.

    Isn’t this all fun – work like a plow horse and continue to swat your tail to keep the flies off. It’s a never ending battle. Except we’re fighting two-legged cockroaches.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: iQ Block Country] Not Downloading’ is closed to new replies.