Support » Plugin: iQ Block Country » [Plugin: iQ Block Country] Error occured: Could not download the GeoIP database

Viewing 15 replies - 1 through 15 (of 37 total)
  • exactly the same here. It doesnt show the directory to download and instal to either.. so seems like a bug

    I thought it just might be permissions?

    It’s weird because the link works but the plug-in is not downloading the file. It would have been nice if the message indicated where to upload the file. However, I found the folder where it is stored. It is simply in the plug-ins folder at:
    plugins/iq-block-country

    It would be a lot nicer to figure out why the plug-in is not automatically downloading the file.

    chmod (change permissions) the plugins/iq-block-country folder to 0757 (writable by the app) – it will then download.

    Do you mean 757? I already have it set to 755 and I get the error message.

    I temporarily changed the permissions to 777 and tried again but still got the same error.

    I guess I found the problem. My server is not letting me change the permissions beyond 755. They said that on their server, it should work if I change it to 644. For some reason, filezilla will not let me change it at all so they are doing it for me. I will post here if I find it works.

    My hosting service changed the permissions to 757 but I still receive the same error.

    This plugin is broke. I attempted several different permission changes and I received the same message as Phil posted above.

    Time to deactivate it and move on.

    Did you update? It was just updated on May 16 and is working now. I was just going to thank Pascal for updating.

    I just got the most recent info and download files:

    On the FAQ page there is a link to download the latest database file:

    http://wordpress.org/extend/plugins/iq-block-country/faq/

    Here is the actual link:

    http://geolite.maxmind.com/download/geoip/database/GeoLiteCountry/GeoIP.dat.gz

    Place the unzipped GeoIP.dat file in the root of the iq-block-country folder.

    I tweeted Pascal but someone else chimed in on another post.

    There is an update of iQ Block Country which fixed the download button in the dashboard so you don’t have to go to maxmind.

    Ugh!

    Well I followed those instructions and the upload failed. Repeat and rinse, same result.

    I’m not sure if I wish to spend any more time on this. The original geoip file was readable in notepad, the new geoip file (date.file) is not.

    The this is a dat file vs. a txt file? Is this the problem with the upload to the server files? Not sure.

    One thing I am noticing is the zip file is downloading to my hard drive as a “gz” and not showing up in the download file up I attempt to upload to the server and extract from there. I fixed this by right clicking and placing it in a container file on downloads but still no go uploading to the server and extracting.

    I extracted with an unzip tool and uploaded the “dat” file and that’s when I received the upload error.

    When it wasn’t working, I was able to download the GeoIP.dat file and manually upload.

    download the GeoIP database from http://geolite.maxmind.com/download/geoip/database/GeoLiteCountry/GeoIP.dat.gz.

    download file, unzip an upload to /plugins/iq-block-country/

    However, with the new update it is working now. Do you have Version 1.0.6 installed?

    I did that but the upload was showing “failed” in my server. I uploaded the unzipped file from the host into the IQ Block Country folder and yes, I have 1.0.6 version.

    I uploaded the zipped file and extracted it in the IP Block Country folder also and that didn’t work either.

    In either case when I return to the plugin in my WP admin area the download button still shows “error….”

    I’ve even deleted the whole thing and started over. I’ve got plenty of experience with WordPress, this is not my normal experience.

    One more try later and that’s it, I have other Internet fish to fry. I’d like this to work as I need to block some specific countries because of serious hacking attempt lately. I’ve manually denied IPs but that too is time consuming.

    You could ask your hosting service to take a look and see if it has anything to do with them. I just had a problem with a different plugin which turned out to be some security settings by my hosting service. They turned it off and my problem went away.

    Another solution is to try this script which I bookmarked a long time ago. I have never tried it. If you try it, I would love to know what you think.
    http://www.12scripts.com/scripts.php?scripts.id=2

Viewing 15 replies - 1 through 15 (of 37 total)
  • The topic ‘[Plugin: iQ Block Country] Error occured: Could not download the GeoIP database’ is closed to new replies.