WordPress.org

Support

Support » Plugins and Hacks » Instapress » [Plugin: Instapress] Error when I try to activate

[Plugin: Instapress] Error when I try to activate

  • I get these errors:

    Warning: Call-time pass-by-reference has been deprecated in /usr/local/pem/vhosts/112327/webspace/httpdocs/wp-content/plugins/instapress/instagram.php on line 306 Warning: Call-time pass-by-reference has been deprecated in /usr/local/pem/vhosts/112327/webspace/httpdocs/wp-content/plugins/instapress/instagram.php on line 309 Warning: Call-time pass-by-reference has been deprecated in /usr/local/pem/vhosts/112327/webspace/httpdocs/wp-content/plugins/instapress/instagram.php on line 311 Warning: Call-time pass-by-reference has been deprecated in /usr/local/pem/vhosts/112327/webspace/httpdocs/wp-content/plugins/instapress/instagram.php on line 777 Warning: Call-time pass-by-reference has been deprecated in /usr/local/pem/vhosts/112327/webspace/httpdocs/wp-content/plugins/instapress/widget.php on line 80 Warning: Call-time pass-by-reference has been deprecated in /usr/local/pem/vhosts/112327/webspace/httpdocs/wp-content/plugins/instapress/widget.php on line 83 Warning: Call-time pass-by-reference has been deprecated in /usr/local/pem/vhosts/112327/webspace/httpdocs/wp-content/plugins/instapress/widget.php on line 85

    http://wordpress.org/extend/plugins/instapress/

Viewing 6 replies - 1 through 6 (of 6 total)
  • I’m also getting this error…

    Same error here:
    Fatal error: Call-time pass-by-reference has been removed in /home/www/public_html/wp-content/plugins/instapress/instagram.php on line 306

    This happened after upgrading to PHP 5.4.4. The site actually gave me a 500 error and I had to disable the plugin to get the site back up. Now it cannot be re-enabled with this error.

    Ok, I found the solution to this: You need to change all the instances of “&$” to just “$”

    In instagram.php:
    Line 306: change &$nextMaxId to $nextMaxId
    Line 309: change &$nextMaxId to $nextMaxId
    Line 311: change &$nextMaxId to $nextMaxId
    Line 777: change &$errorMessage to $errorMessage

    In widget.php:
    Line 80: change &$nextMaxId to $nextMaxId
    Line 83: change &$nextMaxId to $nextMaxId
    Line 85: change &$nextMaxId to $nextMaxId

    Hope that helps.

    That solved it for me, Thanks!

    shagbagboy

    @shagbagboy

    Thanx! This made my day.

    Top work mccomb – thanks for the fix.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Plugin: Instapress] Error when I try to activate’ is closed to new replies.
Skip to toolbar