WordPress.org

Support

Support » Alpha/Beta » Plugin installation failing under WP3-RC1

Plugin installation failing under WP3-RC1

Viewing 12 replies - 1 through 12 (of 12 total)
  • I am having the same problem…. and I have been thru every permission possibility.

    Apparently the last line is supposed to contain the full path to your plugins-directory instead of just “/” according to others who has gotten similar errors on WP2, maybe there’s something wrong with my path setting…?

    @uppfinnarn, I tried changing to the full path of my plugins directory and the same error. Any luck on your end?

    I have a current install of WP3 and it works perfect. I installed it as beta 2 and have updated it nightly…with no problems. Yesterday I downloaded the RC1 and installed a new blog….and it won’t upgrade the core, install plugin’s or themes. I have compared both blogs and I can’t find any differences. So I installed a third blog…..and the same issue. So I installed a fourth blog using WPMU 2.92….and it works perfectly… I am at a loss.

    I’m not sure how to change that directory, is it the ‘dirname(__FILE__)’ statement in wp-config you mean or do you override it some other way?

    it’s in settings->miscellaneous (at least in WP2)

    I don’t seem to have a settings->miscellaneous panel, I think it was removed in WP3

    Settings > Miscellaneous was merged into Settings > Media in WP3

    I tried changing the “Full URL path to files” field to the adress to my root folder on the server, but now it just stops after “Downloading update from http://downloads.wordpress.org/plugin/akismet.2.2.9.zip” and just kills the script, even when I reset the field in the Media configuration. Same thing on installs.

    I also tried overriding the ABSPATH constant in wp-config, but the result didn’t change

    Hey guys, I just registered to post the solution that worked for me.

    I just created the folder:
    wp-content/upgrade

    If it already exists try to delete it and re create it.

    Hope it works!

    Thanks Brett35.. the addition of a “upgrade” directory worked perfect

    I had the same problems as above, I checke the .htaccess file, it was fine, I set the permissions on the wp-content folder and recursed the entire directory with 777 and 775 and 755 .. no change
    I added an uploads folder in the wp-content, and set the path in the Media area of the Dashboard.. no change..
    I installed a fantastico wp 2.9, checked that it was working and then upgraded to 3.0rc1 and the problem appeared in the 3.0 but didnt appear in the 2.9 .. again no change..

    I then added a upgrade folder and wp30rc1 seems to be working perfectly.

    That actually worked, oddly enough. Strange not to catch that error, thumbs down wp. Lucky this is an RC, so no more people had to stand this.

    However, now my upgrader seems to call “exit;” after the first log row, but actually finishes the task in the background, but requires the page to stand open while it happens. The problem is, you don’t know how long that is, and it messes up the sidebar. Anyone know why this is happening?

    brett35, I like you a lot right now, LOL! Thanks!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Plugin installation failing under WP3-RC1’ is closed to new replies.
Skip to toolbar