JavaScript Not Loading: infinitescroll.init.js.php returns a 404 (2 posts)

  1. esdizzle
    Posted 3 years ago #

    Great plugin and thanks to the developers who created and support it!

    I am running wordpress 3.4.1 and using the multisite feature to create a network of sites. I was eager to install the infinite-scroll plugin, but after installing version 2.0b2.120226, completing a network activate on the plugin and loading my blog in a browser I noticed the javascript file /wp-content/plugins/infinite-scroll/infinitescroll.init.js.php is not loading. That is, the response for that resource is returning an http 404. I started to mess around with selectors, but expect the reason the plugin isn't working is because the necessary javascript files are not loading. Has anyone experienced this? Anyone solved this? Any help is greatly appreciated!


  2. doublesharp
    Posted 2 years ago #

    I just solved this exact issue on my site. The problem was that the index.php page was setting 'posts_per_page' => 6 in a custom query, but the value set in "Blog pages show at most" on /wp-admin/options-reading.php was 10. Changing this to 6 so that they match caused the check in infinite-scroll-class.php to succeed:

    $nextpage_no            = intval($current_page) + 1;
    $max_page                       = $wp_query->max_num_pages;
    if ( !$max_page || $max_page >= $nextpage_no )

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Infinite-Scroll
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic