WordPress.org

Forums

Image Widget
send_to_editor from media library doesn't work (3 posts)

  1. lordchammon
    Member
    Posted 3 years ago #

    My actions:
    1. insert a new "image widget" in a sidebar
    2. click into "add image"
    3. go to media library tab and search something
    4. select an image from the results and click "Insert into widget"
    --> doesn't work
    alternate:
    3. go to media library tab and navigate from pagination links to the desired image
    4. click "Insert into widget"
    --> works

    Browsers used:
    + Chrome last version on Mac 10.6
    + Safari last version on Mac 10.6
    + Firefox last version on Mac 10.6
    + Opera last version on Mac 10.6

    I've followed the HTTTP requests and it seems the "image_send_to_editor" filter doesn't execute on media library search.

    Any solution?

    Thanks in advance

    http://wordpress.org/extend/plugins/image-widget/

  2. lordchammon
    Member
    Posted 3 years ago #

    Tested right now:
    Changing in image-widget/resources/js/image-widget-upload-fixer.js:
    jQuery('form#image-form').submit( [...]
    to
    jQuery('form#image-form').live('submit', [...]
    doesn't seem to work

  3. mek8
    Member
    Posted 3 years ago #

    I've also run into this problem. A solution from the plugin devs would be greatly appreciated.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Image Widget
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic