Support » Plugin: Image Widget » [Plugin: Image Widget] Media Library Search Fails to Insert Image into Widget

  • When I go to Add Image and use the Search Media feature of the Media Library to find an Image I want to use and then, once I’ve found the image I want and click on Insert into Widget, no image is inserted. Same thing happens when I want to Change the image, although at that point the option after selecting an image reads Insert into Post, not Widget.

    Also there is no option to select the original image I uploaded into the Media Library, only the modified images are selectable, and my animated Gif then does not animate.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Have you managed to figure out an answer to the first issue you mention? As I am having the same issue. wp 3.1.2 multisite.

    I’m having the same problem. You can select just fine if you use the pagination links, but filtering by date or searching doesn’t work when you click “Insert Into Widget”

    I’m on Image Widget 3.2.5 and WP 3.1.3 and am running into this same issue. I tried disabling all plugins. Unlike alanpuccinelli this issue happens for me regardless of how I navigate to the file in the media manager..

    behavior: can upload file, get to the “insert into widget” button and then the media manager goes blank and just gets stuck.. The console in FF registers this error:
    “win.pb_medialibrary is not a function”
    and in Chrome registers this error:
    “Uncaught TypeError: Object [object DOMWindow] has no method ‘pb_medialibrary’ “

    I just used this plugin on another site last night and it worked fine but I am struggling to see the difference .. I tried disabling all other plugins with no change. Both the site I used last night and the site today are using hte Thesis Theme Framework.

    Any help out there?


    ahh posted too soon.. Apparently I didn’t quite get all of hte plugins tracked. It ends up the “carousel” plugin by BackupBuddy intereferes with the operations in this plugin.

    I have this problem too but not using Backup Buddy. And have also tried the browser upload and disabling the theme.

    Ahhhh it IS the theme! I am using Alyeska

    Is this problem solved? Because I still have this problem and cannot figure out a way to solve it. I deactivated all plugins, and I use Twentyeleven theme.

    As OHOHere and alanpuccinelli said, the “Insert Into Widget” button works, if you take an image from the image library without using the search field. But after using the search field, something is broke and the “Insert Into Widget” button no longer works.

    In my project, I have hundreds of images, so I am really dependent on the search field.

    The only workaround I found, is to re-upload the same image again, so it appears on top of the list. But I hope that there is another solution.

    Same, I’ve reproduced this issue using both WP 3.1 and 3.3 using Image Widget 3.2.11.

    bump. Same prob here …
    WP 3.2.1 and Widget 3.2.11, custom template …

    Does the developper of this extension have a solution?

    This sounds quite similar to the issues I’ve had with uploading an image.

    I’ve posted a solution and notified the developers of my issue and the suggested solution can be found here:

    Let me know if this helps,

    Hi BjornW,

    I’ve installed your new files, unfortenately it does not solve the issue on my site.
    The image coming from the media library can not replace the one currently in place unless it has just been uploaded …


    Elnino3838: thanks for your quick reply. I’m willing to dive into this and see if I can fix it. Could you please describe what you did, what actually happened and what you expected? Similar to my message here:

    Imagine that I need to reproduce your actions in order to fix the issue at hand. Thanks for you help!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Plugin: Image Widget] Media Library Search Fails to Insert Image into Widget’ is closed to new replies.