Support » Plugins and Hacks » [Plugin: Image Widget] Broken in WordPress 3.3

[Plugin: Image Widget] Broken in WordPress 3.3

Viewing 15 replies - 1 through 15 (of 15 total)
  • It was working fine for me on WP 3.3, but I just made a push to 3.2.9 which might fix your issue. Update, clear your cache, and see where you’re at. It could also be a clash with another plugin.

    I agree with jzimmer76. I’ve been using the Image Widget (nice plugin BTW) with WP v3.2.1 without problem.

    I upgraded to WP v3.3 today. The Image Widgets that were already setup prior to updating still work though the [Change Image] button is no longer functional. When adding new widgets the [Add Image] button does not seem to work (which is kind of a problem 😉

    Everything I’ve got is up-to-date. I’ve cleared my cache as you’d suggested. I’ve disabled all other plugins to test for conflicts, but I still can’t get Image Widget (v3.2.9) to work with w/ WP 3.3.

    I assume this is related to the changes made to the Media Uploader in v3.3.

    …oh, and I just checked for JS errors and I noticed on line 95 (image-widget.js):
    tb_show("Add an Image", event.target.href, false);
    the event object you’re using is named ev not event.
    After changing event.target.href to ev.target.href the plugin works again. 🙂

    Whoops! Thanks for the heads-up hasktoken. Looks like I had an issue with caching myself making it work instead of break!

    Just pushed out 3.2.10 – should resolve that.

    w00t! Thanks a lot Matt. Again, thanks for the great plugin.

    Hello, the “add image”-button is still not working. Does someone fix the problem? (I already reinstalled the plugin)

    … I am now using another plugin called “simple image widget” and it works.

    @mister 1: 1) clear your browser’s cache. 2) provide your current version of WP and which browser you use. Can’t be of much help without those.

    @matt Wiebe, I see that you are the developer for the plug-in for image widget.

    I am frustrated out of my ears at this moment. Yes, I have the problem too.

    Yes, I already have the latest version of the plugin and still there is problems.

    If you can – take a few minutes, go to http://www.pchiccups.co.za – yes, it is my site, open it up in Internet Explorer or Firefox, you will then see what happened on the home page.

    It works fine on my blog, under our articles.

    You need to help, it is really frustrating and there isn’t really any other plugin.

    If you can, please mail me from my site.


    Me, too. It worked before updating to 3.3 Now, nothing happens when I click the “Add image” button. I cleared the cache of the browser and WP. Am using Firefox.

    Is a fix coming, Matt? Thanks!

    Hey folks. I have no idea why this wouldn’t be working for anyone – it works without issue for me under WP 3.1, 3.2, 3.3 in all the browsers under the sun …

    As with all plugin-related issues, try deactivating other plugins to see if one of them is causing a conflict.

    Anyway, I made an update that might help. 3.2.11 should be live any moment.

    Dear Matt Wiebe,

    I am sorry to let you know. The plugin is till not working.

    What I am doing:
    1. Latest WordPress 3.3
    2. Latest version of plugin – updated few hour ago
    3. Firefox
    4. Internet Explorer

    On the Home page of my website, I used another plugin so that my website will just look better. Here are the link to the photo of what is happening.

    This screen shot was took in Firefox 7.01

    As you can see of the first picture uploaded – look on the right hand side, the Facebook Logo is of (out of the widget)

    All the other is correct because that is not your plugin that we are using at the moment. The first logo is your plugin and look what is happening.

    How can we get the problem and you not?

    p.s. Yes, I did deactivated the plugin and activated it again and still problems!

    HELP please.

    Mine works now! Thanks for the new update, Matt!

    It does not work for me. I tried everything in this post, have the latest upgrade, cleared cache, etc – nothing. I can’t edit anything so am at a total loss. Guess I’ll need to find a new image editor, which really bums me out. But I can’t not have something on my website for widget images.

    Could this have something to do with PHP versions? I had the widget working perfectly on my local machine (running 5.3.6), then pushed the site to my live server (which runs version 5.2.17) and am now getting this issue.

    The app is great in concept, but unless you leave the image as a link, it won’t work. If you leave the title blank, it leaves a list item dot. I just need the plugin to display an image using nothing other than simple html image tags. Leaving the other things blank simply doesn’t work.

    Hi and thanks for this simple and great plugin…

    I now want to use it on a fresh installation of WP 3.3.1…The ‘add image’ function will bring u to the Media Library…but there is no ‘insert to post’ option for any image…No other plugins installed.

    Any advice…?

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Plugin: Image Widget] Broken in WordPress 3.3’ is closed to new replies.