WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: iframe] Embedded Google Map not showing, reverts to default Vimeo video

[Resolved] [Plugin: iframe] Embedded Google Map not showing, reverts to default Vimeo video

  • Hi, I’ve just installed your plugin and first time around it worked, but I had to recreate my Google Map to centre it slightly differently and now I don’t get a Google map but the default Vimeo Video displayed there with but with the width and height I have specified. The code is cut and pasted directly from the Google Maps page link but with the first < changed to a [ and the </iframe> removed and replaced with a ].

    [iframe width="550" height="300" frameborder="0" scrolling="no" marginheight="0" marginwidth="0" src="https://maps.google.co.uk/maps/ms?msa=0&msid=211918802249396319376.0004cafc66787b593a47c&ie=UTF8&t=h&ll=50.765997,-1.879349&spn=0.130289,0.376968&z=11&output=embed">]

    If I have a syntax error I can’t see it. Under what circumstances does it revert to the default video?

    Many thanks

    http://wordpress.org/extend/plugins/iframe/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author webvitalii

    @webvitaly

    You forget to remove “>” before “]” at the end of the shortcode.

    Should be like this: [iframe width="550" height="300" frameborder="0" scrolling="no" marginheight="0" marginwidth="0" src="https://maps.google.co.uk/maps/ms?msa=0&msid=211918802249396319376.0004cafc66787b593a47c&ie=UTF8&t=h&ll=50.765997,-1.879349&spn=0.130289,0.376968&z=11&output=embed"]

    Plugin Author webvitalii

    @webvitaly

    Oh, I think I’ve understand why you convert iframe code into shortcode like this. Maybe it is because of confusing instruction on the banner.

    I change it a little bit. Is it more understandable now?
    http://wordpress.org/extend/plugins/iframe/

    Thank you webvitaly, I thought I must be doing something very silly but couldn’t see it. My error – your instructions were very clear 🙂

    Thanks again

    Hi, I am having a similar problem with google maps. As it turns out I also had that extra “>” at the end, however, when I removed it, it did not solve my issue, here is my embed code. Thank you for your help in advance, and just like NFWRo, I’m sure I’m doing something silly.

    [iframe width="425" height="350" frameborder="0" scrolling="no" marginheight="0" marginwidth="0" src="https://maps.google.com/maps?f=q&source=s_q&hl=en&geocode=&q=St.+Mary+Parish,+Riverside,+IL&aq=&sll=37.0625,-95.677068&sspn=65.557733,81.826172&ie=UTF8&hq=St.+Mary+Parish,+Riverside,+IL&hnear=&radius=15000&t=m&z=13&iwloc=A&cid=16395177547919849629&ll=41.830531,-87.816398&output=embed"]

    Thank you,
    Anthony

    Plugin Author webvitalii

    @webvitaly

    @adarco: Your shortcode is good.
    I tested it and it shows Google map with the pointer to “St Mary’s Church”. What problems do you have with it?

    Hmm, well thats not good, it is not showing up on my page, take a look:

    Thank you,
    Anthony

    whoops linked that wrong:

    http://stmaryriverside.org/welcome/map-and-directions/

    There we go.

    Plugin Author webvitalii

    @webvitaly

    @adarco: Replace all “&_amp;” (without “_”) symbols into “&” in your shortcode.

    I tried that, with no change. Below is my new short link:

    [iframe width="425" height="350" frameborder="0" scrolling="no" marginheight="0" marginwidth="0" src="https://maps.google.com/maps?f=q&source=s_q&hl=en&geocode=&q=St.+Mary+Parish,+Riverside,+IL&aq=&sll=37.0625,-95.677068&sspn=65.557733,81.826172&ie=UTF8&hq=St.+Mary+Parish,+Riverside,+IL&hnear=&radius=15000&t=m&z=13&iwloc=A&cid=16395177547919849629&ll=41.830531,-87.816398&output=embed"]
    <br /><small><a href="https://maps.google.com/maps?f=q&source=embed&hl=en&geocode=&q=St.+Mary+Parish,+Riverside,+IL&aq=&sll=37.0625,-95.677068&sspn=65.557733,81.826172&ie=UTF8&hq=St.+Mary+Parish,+Riverside,+IL&hnear=&radius=15000&t=m&z=13&iwloc=A&cid=16395177547919849629&ll=41.830531,-87.816398" style="color:#0000FF;text-align:left">View Larger Map</a></small>

    Thank you,
    Anthony

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] [Plugin: iframe] Embedded Google Map not showing, reverts to default Vimeo video’ is closed to new replies.