WordPress.org

Support

Support » Plugins and Hacks » [Plugin: ICS Calendar] Need to say ‘No Events’ when there are none

[Plugin: ICS Calendar] Need to say ‘No Events’ when there are none

  • Hi,

    I like this plugin but it has one flaw; when there are no calender entries you get this error: iCal Events: Error parsing calendar

    Is there a simple way to say ‘There are currently no entries’ ?

    Also, why, when you paste the call ‘[show-ics-events]’ why does it ignore any copy that precedes it and places the events list above the copy?

    Thanks in advance.

    http://wordpress.org/extend/plugins/wordpress-ics-importer/

Viewing 15 replies - 1 through 15 (of 19 total)
  • Ok, I have fixed all the errors you mentioned. The first one was a glitch with the ics parsing function. The second had to do with the way that the events were printed onto the page.

    Both of these should be fixed. Let me know if there are any other problems.

    Thanks for the fixes dolfelt, thy worked a treat 🙂

    There is just one other xhtml error: when there are events to show they are displayed in a list <li></li> but the list is missing it’s unordered tags at beginning <ul> and end </ul>. All I done was to add them to my page like so:

    <ul>
    [show-ics-events]
    </ul>

    Keep up the good work. This plugin is so handy for events 🙂

    Thanks

    Chris

    Ignore above. See that is fixed 🙂

    Hi there,

    This is a great plugin to use with Google Calender. Thanks!

    I have a question:

    1. When I add more than one paragraph in my calender I notice that when this is parsed through to my wordpress page that I get widow ‘p’ tags added (by wordpress). I guess the that the sentences are so long they wrap in wordpress and then wordpress does that annoying thing of adding it’s own tags. See this example: http://paste-it.net/private/a4a5d12/

    Is there an easy fix for this?

    Thanks for your time.

    Britney

    Britney, I tried the exact entry that you had and it did not give me the widowed ‘p’ tags. In fact, there are no ‘p’ tags added. I am using version 2.5, what version are you using. Does this show up in the events, or the calendar?

    Hi dolfelt,

    I am using 2.5, it displays the events just fine but doe not validate as valid xhtml.

    These are my option settings in your script. Not sure if I have done anything wrong here: http://paste-it.net/private/he6db4d/

    As a matter of interest how difficult would it be to show events like this: http://paste-it.net/private/n98c938/

    Thanks for this wonderful plugin 🙂

    That would be easy to do. Go to the settings page and click Date Format >> Custom Formatting. Then you can copy into the box:

    <h3>%event-title</h3>
    <p><em>%date-time%</em></p>
    <p>%description%</p>

    You can use the custom formatting to make whatever format you want. This will bypass all the settings in the script for what you use in the custom format box. Also, new lines in the custom format box are convert to <br />

    I will also look into the xhtml validation if I have time. I should also change the tab since it is slightly misleading.

    Great stuff dolfelt, I didn’t even know those options were available 🙂 That makes things much easier 🙂

    There is one wish-list item I would like to see (though I am not sure if possible). If you don’t intend to use the calender it would be nice to be able to remove the css & jquery from the header. Even if it means just adding some code to the header to remove it.

    Still getting the ‘p’ tags when there are spaces: http://paste-it.net/private/needc7c/
    Is the div tag added by your code?

    Thanks again for all your hard work.

    I found the reason for the <p> tags, and I will look into removing the jquery and css. These will be in the next release

    Thanks again 🙂

    Hi there,

    I just wondered if there was a way to show 1 (the next up and coming) event on my front page while my WP ‘page’ called events show the number of events as governed by my settings in admin.

    That would be very handy 🙂

    Cheers

    There is currently not, but I will be more than happy to include the feature in the next release!

    You work quick my friend 🙂

    Thanks for adding that feature so quick!

    I absolutely love this plugin, it has many uses.

    Many thanks

    Hi all,

    I have been trying this script and just noticed that the dates and time seen to be based on my servers time. My server is in the USA but I am in the UK. Is there a way to use WordPress’s UTC time code?

    Thanks and keep up the good work.

    Steve

    I never thought of that, since my server is in the same timezone.
    Although, should it really matter since the UNIX timecode is converted directly to the date-time format? When converting it doesn’t use the time() function, which would mean that you would not have to account for an offset.

    You might want to check the dates and times of the iCal (ics) file you are using. Make sure that your iCal program isn’t changing the times to match your timezone.

    If you still think this is a problem though, let me know and I will see what I can do. The problem is that if I change it now, others will possibly have issues.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘[Plugin: ICS Calendar] Need to say ‘No Events’ when there are none’ is closed to new replies.