WordPress.org

Support

Support » Plugins and Hacks » ICS Calendar » [Plugin: ICS Calendar] Dire warnings trying to use with 3.0.1!

[Plugin: ICS Calendar] Dire warnings trying to use with 3.0.1!

  • I loved ICS Calendar until my entire site broke. I’m trying to reconstruct it, but get these scary messages when activating the calendar:

    Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead. in /home/content/99/6576099/html/wordpress/wp-includes/functions.php on line 3237

    Notice: register_widget_control is deprecated since version 2.8! Use wp_register_widget_control() instead. in /home/content/99/6576099/html/wordpress/wp-includes/functions.php on line 3237

    Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/content/99/6576099/html/wordpress/wp-includes/functions.php on line 3321

    Warning: Cannot modify header information – headers already sent by (output started at /home/content/99/6576099/html/wordpress/wp-includes/functions.php:3237) in /home/content/99/6576099/html/wordpress/wp-includes/pluggable.php on line 890

    Any suggestions? Some code editing that I’m not comfortable with?

    Also I can’t contact the developer because on his site his “CAPTCHA” code image doesn’t display for copying so I can’t send an email!

Viewing 1 replies (of 1 total)
  • I get the same messages. Will try to fix it. Managed to get rid of the messages using the new wp_register_sidebar_widget and wp_register_widget_control functions. However the plugin still didn’t work,

Viewing 1 replies (of 1 total)
  • The topic ‘[Plugin: ICS Calendar] Dire warnings trying to use with 3.0.1!’ is closed to new replies.
Skip to toolbar