WordPress.org

Forums

iContact Widget
[resolved] We've experienced an error with your request. (12 posts)

  1. mikepoynton
    Member
    Posted 3 years ago #

    I have installed the iContact widget on my blog at http://www.tanktopsflipflops.com. The widget config. panel reads:
    ----------------
    "The widget is active.
    Everything has been configured properly. Good job!

    You can embed the form in post or page content by using the following code: [icontact id=2].

    If you make changes to your form, make sure to click Save!"
    ----------------

    However, when I attempt to submit the required information, I am redirected to the iContact error page at http://www.icontact.com/icontact-error?Invalid+Sign-up+Form+Id.

    I am using WordPress 3.3.1. I have a free iContact account.

    http://wordpress.org/extend/plugins/icontact-widget/

  2. jolaedana
    Member
    Posted 3 years ago #

    I am having this same problem with a client blog. Would love to hear if there's an update coming, or a fix that we can apply in the meantime.

  3. Azarea
    Member
    Posted 3 years ago #

    Same issue here. Any news?!

  4. eatlocal
    Member
    Posted 3 years ago #

    Same issue. It had been working, and I'm not sure when it broke. No support on this?

  5. Zack Katz
    Member
    Plugin Author

    Posted 2 years ago #

    Can you please post (or email to info@katzwebservices.com) the Automatic Signup Form Code from iContact?

  6. Zack Katz
    Member
    Plugin Author

    Posted 2 years ago #

    And links to the active pages would be good, too.

  7. mikepoynton
    Member
    Posted 2 years ago #

    Not an issue at this point. Implemented a workaround. TY!

  8. pamelasproducts
    Member
    Posted 2 years ago #

    Help! I am having the same issue. I am using the shortcode and I am getting the error mentioned above.
    Here is the automatic signup code:

    <style type="text/css">
    .link,
    .link a,
    #SignUp .signupframe {
    	color: #000000;
    	font-family: Arial, Helvetica, sans-serif;
    	font-size: 13px;
    	}
    	.link,
    	.link a {
    		text-decoration: none;
    		}
    	#SignUp .signupframe {
    		border: 1px solid #e0e0e0;
    		background: #ffffff;
    		}
    #SignUp .signupframe .required {
    	font-size: 10px;
    	}
    </style>
    <script type="text/javascript" src="http://app.icontact.com/icp/loadsignup.php/form.js?c=203224&l=15037&f=4400"></script>
    <span class="link"><a href="http://www.icontact.com">Email Marketing</a> You Can Trust</span>
  9. pamelasproducts
    Member
    Posted 2 years ago #

    P.S. It used to work and now it doesn't.
    mikepoynton - if you found a workaround please let me know!

  10. pamelasproducts
    Member
    Posted 2 years ago #

    Nevermind - I think it was an iContact issue.

  11. mikepoynton
    Member
    Posted 2 years ago #

    pamelasproducts:

    It's been so long. I think what I did was to simply create a page with with the iContact form embedded. See http://www.tanktopsflipflops.com/sign-up-for-my-newsletter/. Hope that helps.

    Mike

  12. Zack Katz
    Member
    Plugin Author

    Posted 2 years ago #

    @pamelasproducts - thank you for your Automatic Signup Code. Based on your code, I was able to identify and fix the issue in Version 1.2.2.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • iContact Widget
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic