WordPress.org

Support

Support » Plugins and Hacks » [Plugin: MP6] Plugin Icons do not play nice

[Plugin: MP6] Plugin Icons do not play nice

  • MP6 is fantastic. I love it, and have it installed on practically every site I run. One problem I have noticed — the standard pushpin icon appears on top of other plugins’ CPT icon images in the admin menu. I have noticed others are having the same problem.

    I have begun to use…

    .wp-menu-image img {
    	display: none;
    }

    …to remove these pesky images. This doesn’t always work (glaring at you, Gravity Forms), but does the trick for the most part. Is there a better solution? Couldn’t this be included with MP6?

    Also, I have started a resource for replacing plugin icon images with FontAwesome icons. If you have CSS solutions for additional plugins, please send them to me, and I will add them to this resource. My apologies for posting this is the wrong place! Thanks!

Viewing 2 replies - 1 through 2 (of 2 total)
  • Running into the same issue you mentioned, I found this link on the internet:

    http://hofmannsven.com/2013/laboratory/wordpress-dashicons/

    Can you comment on this?

    Sven’s post outlines basically the same approach I put on GitHub — except I use FontAwesome instead of IcoMoon/SVG. Sven has contributed to the GitHub resource I mentioned, adding dependency checks for MP6.

    The number of icons you need and how you would like to load them is up to you — flat icon resources abound. I prefer the FontAwesome stack, as it is a great, free resource. I also prefer to load the whole icon stack, so if I need to add another icon down the road, I can simply A) choose one from FontAwesome’s cheatsheet and B) add it with two lines of CSS.

    Hope this helps! Thanks!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Plugin: MP6] Plugin Icons do not play nice’ is closed to new replies.