WordPress.org

Forums

[Plugin: ic BeSocial] No funciona (25 posts)

  1. minilobo
    Member
    Posted 5 years ago #

    ¿ Qué código tengo que poner en la plantilla ? Tengo varios plugins sociales, pero no los quiero quitar hasta comprobar que este va bien …. :D

    Y automaticamente no me funciona ...

    http://wordpress.org/extend/plugins/ic-besocial/

  2. Jos Cuesta
    Member
    Posted 5 years ago #

    Comprueba las opciones en la página correspondiente del panel de administración.

  3. minilobo
    Member
    Posted 5 years ago #

    Comprobado ... todo marcado. Mi API de bitácoras, mi API y user de Bit.ly. Los caches desconectados, limpios y conectados ...

    Y no me aparece ni en la portada ni en las entradas individuales ... ¿igual tienen conflicto con algun otro plugin que coloca botones al final ...?

  4. Jos Cuesta
    Member
    Posted 5 years ago #

    Es raro, porque sí que carga la hoja de estilos y las variables de JS están bien. Pero no inserta los botones al final del post... Supongo que en la plantilla usas the_content() para mostrar el post, ¿no?

  5. minilobo
    Member
    Posted 5 years ago #

    Sí,

    <?php the_content('<p class="serif">Read the rest of this entry »</p>'); ?>

    ¿ No es posible colocarla manualmente ? Tengo varios botones, y me gusta ponerlos a mi manera de todas formas ...

  6. Jos Cuesta
    Member
    Posted 5 years ago #

    Actualiza a la versión 1.3.2 cuando esté disponible (unos 15 minutos). Podrás mostrar los botones con:
    <?php global $ic_besocial; echo $ic_besocial->showButtons(); ?>

  7. minilobo
    Member
    Posted 5 years ago #

    mmm, lo he actualizado y colocado el código en la portada y en las páginas individuales.

    En las páginas individuales se ve perfecto (aunque alineado a la derecha), pero en la portada no aparece ....

    Y otra cosa, los datos de twitter no son del todo correctos .. tenía montones de twitts que no los recoge ... aunque los nuevos twitteados desde el plugin van perfecto.

    Me gusta la idea :D, a ver si descubres lo de la portada

  8. Jos Cuesta
    Member
    Posted 5 years ago #

    Lo de la portada es por diseño, sólo se muestra en los posts individuales. Lo de la alineación es herencia del blog de Maikelnai. Como eres el segundo que lo menciona probablemente los centre en la siguiente versión.

    Respecto a lo de Twitter funciona de una forma un poco extraña: lo que cuenta no son los retweets, si no las veces que la gente ha hecho click en la URL de bit.ly, que es como funciona el Easy Retweet Button (el script en el que me basé para la parte de Twitter). Con la API de bit.ly no se puede hacer mucho más.

    Si conoces alguna forma de contar efectivamente los retweets lo miraré.

  9. minilobo
    Member
    Posted 5 years ago #

    Si se pueden sugerir cambios, personalmente preferiría tener un par de opciones:

    - Aparecer en portada: S/N
    - Aparecer en los feeds: S/N
    - Alineación: Derecha / centro / Izquierda

    Es que cada uno tiene sus manías ... a mi me gustaría tener los botones en la página principal también, y que estuvieran alineados a la izda .. :)

    Sobre los RTs, http://www.backtype.com/ tiene una API bastante potente. Yo uso su plugin http://www.backtype.com/plugins/tweetcount para que se incluyan los tweets como comentarios y va bastante bien. Igual te sirve.

  10. impressgroupsc
    Member
    Posted 5 years ago #

    Pues he hecho lo que poneis aqui y he situado los botones en la cabecera del mensaje incluyendo

    <?php the_content('<p class="serif">Read the rest of this entry »</p>'); ?>

    en el archivo single.php. El problema es que me los repite al final del post.

    Como puedo quitar los del final?

    Y puestos a sugerir alguna cosa, seria interesante poder quitar o poner (segun gustos), el nombre de la red social (facebook, twitter, etc.) y asi poder tenerlo en un tamaño mas dicreto.

    Un saludo y felicidades por elplugin.

  11. Jos Cuesta
    Member
    Posted 5 years ago #

    No hace falta que edites la plantilla (single.php), los botones se insertan automáticamente, por eso te salen duplicados.

    En la próxima versión intentaré dar una solución a este tipo de cosas para que cada uno los ponga donde y como quiera fácilmente.

  12. Jos Cuesta
    Member
    Posted 5 years ago #

    En la nueva versión se puede cambiar la posición de los botones: encima del contenido, debajo del contenido, o se insertan manualmente con ic_BeSocial_Buttons().

    También se puede cambiar la alineación: al centro, a la izquierda o a la derecha.

  13. impressgroupsc
    Member
    Posted 5 years ago #

    Muchas gracias, que velocidad.

  14. impressgroupsc
    Member
    Posted 5 years ago #

    He intentado modificar el archivo besocial.php para traducir los mensajes de 'Share this on' etc que aparecen al pasar con el raton por encima de los iconos, pero en cuanto cambio algo en el archivo y lo subo, deja de funcionar.

    Estoy haciendo algo mal?

    Puestos a pedir, seria interesante poder activar o desactivar los nombres de las redes sociales para que asi solo apareciese el icono (bastante significativo) y ocupase menos espacio.

    De momento he reducido los iconos un poquito.

    Un saludo.

  15. Alberto Navarro
    Member
    Posted 5 years ago #

    Yo lo he traducido y me sigue funcionando, el único problema que tengo es que no me aparece el contador aún teniendolo activado en el panel de opciones.

    Saludos!!!

  16. Jos Cuesta
    Member
    Posted 5 years ago #

    El plugin está preparado para ser traducido, falta generar el fichero PO. En cuanto pueda añado el PO y MO para el español.

  17. Jos Cuesta
    Member
    Posted 5 years ago #

    Ya está la versión en español.

  18. Juan_Ro
    Member
    Posted 5 years ago #

    Buenas, hay forma de poner los botones en portada? Es decir en index.php, en lugar de que solo aparezcan cuando entras en el post.

    Gracias.

  19. Jos Cuesta
    Member
    Posted 5 years ago #

    De momento no, puede que en una próxima versión.

  20. javierdeleon
    Member
    Posted 5 years ago #

    Hola Jose,
    acabo de instalar tu plug y tengo el problema de que en algunos post me sale el botón de twitter y en otros no, bueno relamente solo me sale el botón de twitter en el último post en el resto no.

    ¿Podrías ayudarme? Mi web es laislatuerta.org

    Gracias y felicidades por tu trabajo.

    Por cierto, esperaré a la nueva versión ya que también estoy interesado en poner los botones en la portada.

  21. javierdeleon
    Member
    Posted 5 years ago #

    Lo del twitter solucionado, lo había configurado mal.

  22. azathyel
    Member
    Posted 4 years ago #

    Hola, tengo dos problemas:

    - Primero, por más que he eliminado el plugin TweetMeme (desactivado y luego eliminado), no me sale el módulo de Twitter del plugin. Sí me salen los otros tres...

    - Segundo, de forma aleatoria me da el siguiente error:

    Fatal error: Cannot use object of type WP_Error as array in /home/chs/borjaventura.com/home/html/wp-content/plugins/ic-besocial/besocial.php on line 456

    Me podríais ayudar? Mil gracias

  23. pako.alanis
    Member
    Posted 4 years ago #

    José Gracias por tu plugin y felicidades, es un excelente trabajo! he leido todos los comentarios anteriores y no encontre la respuesta a mi necesidad.

    Necesito que los botones tambien me aparescan en las paginas individuales, en los post me aparecen sin problema, he editado page.php y agregue ic_BeSocial_Buttons() pero aun asi no aparecen... que debo hacer?

  24. Jos Cuesta
    Member
    Posted 4 years ago #

    @azathyel: Comprueba los datos de bit.ly (el nombre de usuario distingue mayúsculas de minúsculas). El segundo error se soluciona actualizando a la última versión (1.6), ocurría cuando había un error al obtener la URL corta.

    @pako.alanis: En la última versión (1.6), abre el fichero besocial.php y en la línea 299 sustituye: if ( is_single() ) { con if ( is_single() || is_page() ) {.

  25. Tim Rogers
    Member
    Posted 4 years ago #

    Hola Jose, hay un problema que ya lo planteó otra persona por lo que lei y lo mismo me pasa a mi. El plugin anda de maravillas, salvo que no me muestra los contadores. Obviamente es algo de mi web y no del plugin (digo esto porque en otros sitios me funciona bien), pero tienes idea que puede ser?
    Gracias por tu respuesta.

Topic Closed

This topic has been closed to new replies.

About this Topic