Plugin I created getting error (3 posts)

  1. uncommonjoe
    Posted 8 years ago #

    Hey, I created a [dumb] plugin and it works fine in my WordPress (2.1.3). I uploaded it to another WordPress blog of mine and it didn't work. I get this error when I try to activate it:

    Warning: Cannot modify header information - headers already sent by (output started at /home/.central/username/domain.com/wp-content/plugins/random-banner-rotator.php:1) in /home/.central/username/domain.com/wp-includes/pluggable.php on line 275

    You can download it here.

    A few friends who have various versions of WP also tried it and all got the same error. What's the problem? It works fine on mine.


  2. whooami
    Posted 8 years ago #

    Open the plugin in wordpad.

    What do you see BEFORE the opening <?php ????


    remove them.

  3. uncommonjoe
    Posted 8 years ago #

    Wow crazy! That was the problem! Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic