WordPress.org

Support

Support » Plugins and Hacks » Hyphenator » [Resolved] [Plugin: Hyphenator] Configuration Not Saved?

[Resolved] [Plugin: Hyphenator] Configuration Not Saved?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author e2b

    @e2b

    That’s odd. Did you get a confirmation message after you clicked on “Save Changes”? Are there any error messages? Do you have JavaScript disabled?

    JavaScript is enable (default Google Chrome configuration) and there are no error messages while I get a confirmation message after saving my configuration.

    Plugin Author e2b

    @e2b

    I just tried to reproduce your error without without success. I did a clean install of the plugin, tested with Google Chrome and also checked the source code for deprecated options.

    Are the new settings at least used at your website while not displayed in the WordPress backend? Do you have similar problems with other plugins? You may try if settings of other plugins are saved. Which WordPress, PHP, MySQL and plugin versions are you using?

    The settings are saved in the WordPress database using the default functions available for plugins.

    Thanks, e2b. I have no similar problems with other plugins. I will get back to you as soon as I can provide further information.

    The settings are not used (and neither written into the options table in the DB. Strange … strange, BTW, is also that Hyphenator doesn’t work at all for this particular website, not even with the default configuration. Any ideas?

    Plugin Author e2b

    @e2b

    Very strange. I’m using the default WordPress function calls to write and read the plugin settings. Maybe something is wrong with your MySQL database or your WordPress installation. But it’s still confusing that other plugins work fine. Have you tried installing a random plugin you haven’t used before and see if the configuration works there?

    The plugin should work with every text as long as you have set up your preferred language and the class name correctly. Since version 4.0.0 you can force a language even if the lang-attribute is not used in your template. In case of your blog named like your username the class “entry-content” (without quotes) would be correct. Do you know how to write CSS?

    If Hyphenator is activated and configured you should see something like this in the source code of your website:

    <!-- Hyphenator for WordPress -->
    <script src="http://example.com/wp-content/plugins/hyphenator/Hyphenator.js" type="text/javascript"></script>
    <script src="http://example.com/wp-content/plugins/hyphenator/patterns/de.js" type="text/javascript"></script>
    <script type="text/javascript">
    	Hyphenator.config({
    		classname: 'entry-content',
    		remoteloading: false,
    		defaultlanguage: 'de'
    	});
    	Hyphenator.run();
    </script>

    The default configuration uses the class name “hyphenate” and needs a lang-attribute in the HTML structure. Otherwise it won’t work.

    I had a similar problem while using SSL for admin. Fixed it while editing line 18 of hyphenator/plugin.php in Version 4.0.0:

    old:

    $hyphenator_options_page = get_option(‘siteurl’) . ‘/wp-admin/admin.php?page=hyphenator/options.php’;

    new:

    $hyphenator_options_page = site_url() . ‘/wp-admin/admin.php?page=hyphenator/options.php’;

    http://core.trac.wordpress.org/ticket/10198

    Plugin Author e2b

    @e2b

    Thank you very much for the hint! I’ve updated the current plugin version. Please note this is a silent update, so you have to uninstall and reinstall the plugin or manually unzip the new download to the WordPress plugin folder.

    Perfect!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] [Plugin: Hyphenator] Configuration Not Saved?’ is closed to new replies.
Skip to toolbar