WordPress.org

Support

Support » Plugins and Hacks » [Plugin: HubSpot for WordPress] Version bump to 1.6.0 and still broken

[Plugin: HubSpot for WordPress] Version bump to 1.6.0 and still broken

Viewing 12 replies - 1 through 12 (of 12 total)
  • I’m not sure anyone from HubSpot is monitoring these threads. I used to work on the plugin but do not have commit access anymore. I’ll take a look on my end to see if I can reproduce it but ultimately I can only tell you how to fix it and can’t update the plugin itself.

    Would have chimed in earlier but was hoping someone else would step up. Last support request was 5 months ago and there hasn’t been much activity since so I’m not sure they know to check up on this.

    Terence
    Participant

    @pubdirltd

    I have emailed someone in their office and hopefully he can find out why nobody from HubSpot seems to be tasked with following this community.

    Hi Terence. I’m still not able to recreate the problem on my end. It may be another plugin or theme manipulating the WordPress query which is affecting the results in that box.

    In the meantime you can insert the shortcodes manually using the following syntax [hs_action id="1, 2, 3, .."]

    All you need to do is provide the id attribute of the shortcode with a list of the CTA ids you want to randomly display. Hopefully this helps while I try work out how to make sure nothing else affects the query in that popup window.

    Terence
    Participant

    @pubdirltd

    Thanks very much Jon, I’ve tested it out and it does in deed call the right CTAs. At least I can get on designing my CTAs now in the knowledge that I will be able to show, rotate and test them. Many thanks.

    Great. I re-wrote the bit that displays the call to actions within the shortcode popup. I put it up on GitHub for the time being. Going to try and keep that as closely synced with the official version so I can keep some of the functionality my clients rely on that are missing from the latest official version. https://github.com/jonbish/hubspot/

    Terence
    Participant

    @pubdirltd

    Jon,

    Sorry, no, that’s not what I said. WordPress only shows the CTA if I enter the shortcode manually into the page.

    I have installed your latest version and you can see here that now instead of seeing ALL my posts as CTA custom post types it just sees four of them… http://awesomescreenshot.com/035a3vr6f

    Also, because you’ve kept the same name/version HubSpot’s own version sees itself as an update. I think you either need to change the name or come up with your own version numbers ahead of HubSpot’s.

    So just to recap, entering CTA number calls manually into the page works with both your update and the original, however the original shortcode popup sees all of my posts as CTA custom post types, but the update can only see four posts and thinks they are CTAs custom post types.

    Sorry I don’t have any better news to report.

    Terence.

    Terence
    Participant

    @pubdirltd

    Should have said “not what I meant”, not “not what I said”.

    Sorry for the confusion.

    Terence.

    Thanks this is what I needed. I’ll come up with a new version/name so the udpate wont conflict and I’ll try something new to make the CTAs displays in that box.

    Plugin Author David Cancel
    Member

    @dcancel

    Jon,

    I’ll add you back to the committers sorry about that!

    Cheers,
    David

    Terence
    Participant

    @pubdirltd

    Guys, it looks like to me that the 1.6.4 update is using Jon’s code because on this update too the the shortcode popup can only see four posts which it thinks CTAs custom post types. For me this is a retrograde step since the 1.6.0 version confused ALL the posts with CTA custom post types, not just the first four.

    Terence
    Participant

    @pubdirltd

    I just added 1.6.4 to another blog on the same server and got a better result. This time the shortcode popup can see I have only one CTA custom post type entered, but when I select it and insert it into the page, it simply shows “[hs_action]” and no CTA page ID.

    Terence
    Participant

    @pubdirltd

    @jon @david

    I just checked again and when I added 1.6.4 to the original blog theme I got the same result, i.e. I can only see four posts which it thinks CTAs custom post types.

    [ Please do not bump, that’s not permitted here. ]

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Plugin: HubSpot for WordPress] Version bump to 1.6.0 and still broken’ is closed to new replies.