Support » Plugin: HTTP Authentication » [Plugin: HTTP Authentication] How to authenticate when REMOTE_USER = name@DOMAIN

  • Resolved ian.armstrong


    I have been using basic authentication via an Apache Kerberos module for sometime. It authenticates users to an Active Directory DC. I have installed this plugin to integrate WordPress authentication.

    REMOTE_USER variable is set to username@OUR.DOMAIN and so no match occurs. I am not able to create usernames in the that format since WordPress allows only lower case and no @ symbols.

    To the best of my knowledge, although it has been a few years since I set it up, there is no way to change the REMOTE_USER value to strip the @domain part (which I am assuming is the problem).

    How can I integrate these two systems?

    Many thanks.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi Ian,

    I have not tested that specific setup, but you may find that your Apache module passes another environment variable containing only the username. Try dumping the environment variables on a throwaway PHP page that is under the same domain. For example:

    <?php print_r($_SERVER); ?>

    If you find one matching your usernames, specify it in the HTTP Authentication configuration in the “$_SERVER variables” option.

    Let us know your results!

    Many thanks Daniel,

    PHP_AUTH_USER in _SERVER variables setting has fixed the problem.


    Hi There,

    I have setup kerberos with Active Directory,
    But whenever i access the URL, the application says
    “Unable to sign you in with your desktop credentials.
    Please try again with different credentials.
    Your session has timed out.”

    Could any1 please help to sort it out?


Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: HTTP Authentication] How to authenticate when REMOTE_USER = name@DOMAIN’ is closed to new replies.