Support » Plugin: HTML5 AV Manager for WordPress » [Plugin: HTML5 AV Manager for WordPress] No video views

  • hi
    I activated the latest version of the plugin on WP 3.3.1, added a video in the settings, and to a page but nothing is showing when browsing to the page. It appears that something is broken in views.. The View Editor has a blank placeholder and Create New View, Audio, Video, Title and an Add New View button.. but none of those seem to do anything. Any ideas ?
    thanks,
    Ben

    http://wordpress.org/extend/plugins/html5avmanager/

Viewing 10 replies - 1 through 10 (of 10 total)
  • maybe paths are incorrect: here’s an error message..

    Warning: copy(/var/www/vhosts/domain.com/httpdocs/wp-content/videoaudio/views/setting.php): failed to open stream: No such file or directory in /var/www/vhosts/domain.com/httpdocs/wp-content/plugins/html5avmanager/html5avmanager.php on line 141 Warning: copy(/var/www/vhosts/domain.com/httpdocs/wp-content/videoaudio/views/video-default.php): failed to open stream: No such file or directory in /var/www/vhosts/domain.com/httpdocs/wp-content/plugins/html5avmanager/html5avmanager.php on line 142 Warning: copy(/var/www/vhosts/domain.com/httpdocs/wp-content/videoaudio/views/video-xml.php): failed to open stream: No such file or directory in /var/www/vhosts/domain.com/httpdocs/wp-content/plugins/html5avmanager/html5avmanager.php on line 143 Warning: copy(/var/www/vhosts/domain.com/httpdocs/wp-content/videoaudio/views/audio-default.php): failed to open stream: No such file or directory in /var/www/vhosts/domain.com/httpdocs/wp-content/plugins/html5avmanager/html5avmanager.php on line 144 Warning: copy(/var/www/vhosts/domain.com/httpdocs/wp-content/videoaudio/views/audio-xml.php): failed to open stream: No such file or directory in /var/www/vhosts/domain.com/httpdocs/wp-content/plugins/html5avmanager/html5avmanager.php on line 145

    Got it working by :

    – commenting out lines 138 to 147 in html5avmanager.php.

    – and manually made /wp-content/videoaudio/views, then copied the audio-default.php, audio-xml.php, setting.php, video-default.php, video-xml.php files from /wp-content/plugins/html5avmanager/view/videoaudio/ into the new directory

    Plugin Author CJ_Jackson

    (@cj_jackson)

    Hello straddieplastic,

    This sound like a permission (chmod) problem. Is wp-content and the plugin folder set to 755?

    Cheers,
    Chris.

    hi Chris
    I changed permissions to 755, now I can see the views, but am getting an error when adding a video. This shows in the editor after adding a jpeg and clicking the ‘save and open editor’ button:

    Fatal error: Call to a member function getType() on a non-object in /var/www/vhosts/domain.com/httpdocs/wp-content/plugins/html5avmanager/html5avmanager.php on line 421

    If I go back to the Audio & Video Manager page, the post has been saved, but without it’s poster jpeg, and i get this error:

    Warning: getimagesize(/var/www/vhosts/mydomain.com/httpdocs/wp-content/videoaudio/2012/02/test/myimage.jpg): failed to open stream: No such file or directory in /var/www/vhosts/mydomain.com/httpdocs/wp-content/plugins/html5avmanager/api.php on line 141 Warning: Division by zero in /var/www/vhosts/mydomain.com/httpdocs/wp-content/plugins/html5avmanager/api.php on line 144 Warning: Division by zero in /var/www/vhosts/mydomain.com/httpdocs/wp-content/plugins/html5avmanager/api.php on line 145

    Any thoughts on that ?
    thanks
    Ben

    Plugin Author CJ_Jackson

    (@cj_jackson)

    Hi Ben,

    Try updating to 0.2.6, see if that fixes the problem.

    Cheers,
    Chris.

    Hi Chris.

    Getting close, getType error is not showing, but still nothing is uploading.

    I traced this error:
    Warning: file_put_contents(/var/www/vhosts/mydomain.com/httpdocs/wp-content/plugins/html5avmanager/lib/uploadify/mydomain.com.json): failed to open stream: Permission denied in /var/www/vhosts/mydomain.com/httpdocs/wp-content/plugins/html5avmanager/html5avmanager.php on line 105 which suggests that the plugin is looking for a json file with my domain name in lib/uploadify. I’ve changed the name of json file that was in lib/uploadify to match my domain (looked like it had your domain on it), and changed the contents of that to match my paths.. all good now, but would be worth updating the plugin to fix that.

    BTW, there are a few notices for undefined variables showing for this plugin.

    Thanks for the quick fixes, great plugin 🙂
    Ben

    Plugin Author CJ_Jackson

    (@cj_jackson)

    Hi Ben,

    Thanks,

    Actually it’s check to see if ‘mydomain.com.json’ (depends on the domain) exists, if not it’s will try to create the file with the setting inside.

    Anyway I added a new line that will on the next version of the plugin, ‘chmod(dirname($uploadify_setting_file), 0755);’ just above where the warning was originating.

    What are the names of the undefined variables?

    Cheers,
    Chris.

    ah OK.

    Here’s the notice:

    Notice: Undefined variable: src_attribute in /var/www/vhosts/domain.com/httpdocs/wp-content/plugins/media-element-html5-video-and-audio-player/mediaelement-js-wp.php on line 428 Notice: Undefined variable: type_attribute in /var/www/vhosts/domain.com/httpdocs/wp-content/plugins/media-element-html5-video-and-audio-player/mediaelement-js-wp.php on line 428 Notice: Undefined variable: mp3_source in /var/www/vhosts/domain.com/httpdocs/wp-content/plugins/media-element-html5-video-and-audio-player/mediaelement-js-wp.php on line 430 Notice: Undefined variable: flv_source in /var/www/vhosts/domain.com/httpdocs/wp-content/plugins/media-element-html5-video-and-audio-player/mediaelement-js-wp.php on line 432 Notice: Undefined variable: wmv_source in /var/www/vhosts/domain.com/httpdocs/wp-content/plugins/media-element-html5-video-and-audio-player/mediaelement-js-wp.php on line 433 Notice: Undefined variable: captions_source in /var/www/vhosts/domain.com/httpdocs/wp-content/plugins/media-element-html5-video-and-audio-player/mediaelement-js-wp.php on line 435 Notice: Undefined variable: loop_option in /var/www/vhosts/domain.com/httpdocs/wp-content/plugins/media-element-html5-video-and-audio-player/mediaelement-js-wp.php on line 447 Notice: Undefined variable: mediahtml in /var/www/vhosts/domain.com/httpdocs/wp-content/plugins/media-element-html5-video-and-audio-player/mediaelement-js-wp.php on line 454

    Plugin Author CJ_Jackson

    (@cj_jackson)

    Aha, well that not the problem of my plugin but somebody else plugin.

    http://wordpress.org/extend/plugins/media-element-html5-video-and-audio-player/

    ah of course. sorry about the confusion. I’ve been trying a few !
    thanks
    Ben

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Plugin: HTML5 AV Manager for WordPress] No video views’ is closed to new replies.