WordPress.org

Support

Support » Plugins and Hacks » HTML Mode Locker » [Plugin: HTML Mode Locker] Lock one page not all of them

[Plugin: HTML Mode Locker] Lock one page not all of them

  • Sheila

    @hoffmangraphics

    Just installed this. I’m getting this error after installation on every page I switch to:
    Warning: call_user_func(html_mode_lock_settings) [function.call-user-func]: First argument is expected to be a valid callback in /home/oozandoz/public_html/wp-admin/includes/template.php on line 1102

    Screenshot of same: http://awesomescreenshot.com/092smat26

    I think that problem is gone now that I’ve selected Pages in the settings. HOWEVER, your plugin says we can lock on a per item basis. As far as I can see it leaves all my pages locked in the mode it was in at the time I installed. I just want to lock one page. Is that possible? HOW?

    http://wordpress.org/extend/plugins/html-mode-locker/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Max Chirkov

    @maxchirkov

    Hi there,

    That is not an “error” – it’s just a warning, which means nothing is broken. There are 2 reasons why you seeing this: 1 – you have WordPress debug activated; 2 – PHP error handling set to output warnings (that is not recommended on production servers).

    I’ll make sure the warning goes away in the next update. Let’s figure out why the locking issue.

    When you check your specific content type in the Settings => Writing, you should see a Meta Box called “HTML Mode Locker” in the post editor on right right hand side (sidebar). There is only 1 checkbox – to lock the current post in HTML mode. When you click on it and save your post, ONLY THAT particular post will be locked in HTML mode. The rest of your posts and pages will still have both Visual and HTML modes available to them.

    Let me know if this helpful or not. If it is and the plugin works as intended, then I will release an update to remove the warning message.

    Thanks!

    Sheila

    @hoffmangraphics

    Perfect…thanks so much. I guess I wasn’t looking hard enough. It might be useful to have a little more guidance for newbies. Now that I know where to look I see the check box and it does work. I installed it on another site and got that error again. It’s disconcerting. So getting rid of it next update is a good idea. I’d suggest two brief sentences in the plug-in interface that says something like: Enable in Settings-Writing, then check in top right of any item you’re editing.

    Plugin Author Max Chirkov

    @maxchirkov

    Thanks for your input. I’ll think of a way to make it more intuitive for others.

    As for the Warning – have you updated to version 0.2? It should remove all warnings. Please let me know.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: HTML Mode Locker] Lock one page not all of them’ is closed to new replies.
Skip to toolbar