Support » Plugin: List Last Changes » Plugin hides the content of the page (page builder plugin)

  • Resolved Mordechaj

    (@mordechaj)


    Hi
    On the home page, I have a list last changes widget in page builder plugin (Rocked theme)

    List last changes stopped working yesterday (wordpress 5.2.0). The page is invisible (body).
    Only the header and footer is shown. The entire page builder is invisible.
    Afer update wordpress to 5.2.1 nothing happened, it’s the same.
    I had to disable list last changes plugin.

    • This topic was modified 4 months ago by  Mordechaj.
Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author rbaer

    (@rbaer)

    Hi Mordechaj

    What did change yesterday on your site that caused list Last changes to break? Did you update WordPress to 5.2, updated list Last changes, updated any other Plugin or Theme or created just a new Page or Post?

    Greetings

    Mordechaj

    (@mordechaj)

    This is very strange because I didn’t update anything.
    I have the latest version of the plugin.
    Wordpress has updated itself today, the plug stopped working yesterday.
    The plugin broke down after creating some new pages.
    The pages have a very long title, maybe that’s why? (107 characters + 22 spaces)

    • This reply was modified 4 months ago by  Mordechaj.
    Plugin Author rbaer

    (@rbaer)

    That is at least a starting point for investingating it. I will not be able to have a look on it the next 7 days but I will have a look afterwards.

    Mordechaj

    (@mordechaj)

    OK, thanks.

    P.S. I translated your plug into Polish language 🙂

    Plugin Author rbaer

    (@rbaer)

    Some more questions:
    – in which variant do you use list Last changes? The widget, the shortcode or the block element?
    – do you list the latest page updates, post updates or both?
    – can you send me a list of all used plugins and the used theme via DM to rbaer@gmx.ch?

    Thanks for translate the plug-in. Would you like to become translation editor for this plug-in? You would then be able to approve new translations yourself.

    – in which variant do you use list Last changes: widget in the “page builder” plugin
    – do you list the latest page updates, post updates or both: only pages updates
    – can you send me a list of all used plugins and the used theme: I sent you.

    Yes, you can add me as translation editor for this plug-in.

    Plugin Author rbaer

    (@rbaer)

    Unfortunately I’m not able to reproduce the problem on my test page. Could you try the steps described in the following tutorial:

    https://www.wpbeginner.com/wp-tutorials/how-to-fix-the-wordpress-white-screen-of-death/

    Thanks a lot.

    PS: PTE request is created.

    On my test page everything is fine too.

    I did everything what is written in the guide but it didn’t help. I even reinstalled the plugin.

    The widget with the last posts works correctly. The problem is only with the last pages. I have a lot of pages and I add new ones all the time.

    Perhaps the problem is with the database? I optimized the database but nothing has changed.

    • This reply was modified 3 months, 3 weeks ago by  Mordechaj.
    Plugin Author rbaer

    (@rbaer)

    Some more questions:

    Were you able to increase the Memory Limit (like described in https://www.wpbeginner.com/wp-tutorials/fix-wordpress-memory-exhausted-error-increase-php-memory/ )?

    Did you try to disable other plugins but leaving List Last Changes enabled? Does the problem still occure?

    Have you enabled the debug output (like described in the chapter “Enable Debug Mode to Catch Errors in WordPress” in https://www.wpbeginner.com/wp-tutorials/how-to-fix-the-wordpress-white-screen-of-death/ )? Did you get some more information on the screen or in the created log file?

    PHP Memory Limit: 256M

    After disabling all plugins, list last changes works.

    Debug.log:

    [13-Jun-2019 10:53:04 UTC] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 4194304 bytes) in ********/wp-includes/taxonomy.php on line 829

    [13-Jun-2019 10:53:04 UTC] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 82 bytes) in ********/wp-includes/class-wp-term.php on line 198

    [13-Jun-2019 10:53:04 UTC] PHP Fatal error: Unknown: Cannot use output buffering in output buffering display handlers in Unknown on line 0

    I have 6.106 pages for now.

    • This reply was modified 3 months, 1 week ago by  Mordechaj.
    Plugin Author rbaer

    (@rbaer)

    > After disabling all plugins, list last changes works.
    I expected that result.

    From the first two error messages it gets clear that the php memory limit is 128MByte, although you set it to 256MByte. This means your web hosting service provider does not allow WordPress to increase PHP memory limit (or not higher than 128M). You will need to ask your web hosting provider to increase your PHP memory limit manually (or, if you have access to that file, set it in php.ini: “memory_limit = 256M”).

    Ok, I will write to the hosting provider and I will let you know if it works.

    Mordechaj

    (@mordechaj)

    You were right, the limit was set to 128M. Now the plugin works without a problem. Thanks.

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.