[resolved] [Plugin: Health Check] No Message Generated (10 posts)

  1. hartley_h
    Posted 5 years ago #

    My understanding is that when I activate the health-check plug-in I should get a message telling me whether I have the proper version of PHP and MySQL for version 3.2 of WordPress. Where does this message appear? I can activate and deactivate the plugin but no message appears. Is there only a message if the server WILL support WP3.2 but NO message if it will not?

    I'm running CentOS 5.3 (basically Red Hat Enterprise Server 5) which only has PHP 5.1.6, unfortunately, so am I DOA?

  2. The message should appear at the top of the page when you activate the plugin.

    Right under the message that says the plugin is activated.

    Do you not see any message apart from the one which tells you the plugin is activated?

  3. docwhat
    Posted 5 years ago #

    I only see the activation notice. I tried disabled and re-enabling it and it still only showed the activation notice.

  4. hartley_h
    Posted 5 years ago #

    Correct, like docwhat, I do not see any message under the one that says the plugin has been activated.

    My PHP version is 5.1.6 so I know what it should be showing me, in any case. Since CentOS 5 will most likely not get PHP 5.2, I won't be able to go beyond WP 3.1 until I can upgrade to CentOS 6, which won't even be released until late this fall or early next year at the earliest. Stable platforms are great unless the software that runs on them moves too much faster than they do. Oh well.

  5. hartley_h
    Posted 5 years ago #

    I have two installations of wordpress on the same machine. One installation hosts a single blog while the other uses Virtual MultiBlog to manage about a dozen blogs. My prior tests were on the multiblog installation. I just upgraded the other installation and the health-check plugin works there. The obvious suspicion, therefore, is that the changes made for virtual multibloging somehow interfere with this plugin. FWIW, I just updated the virtual multiblog additions to the most recent version with no change to the results here.

    So, I don't know for sure that this is the problem and I certainly don't know what the solution is, but it appears this is a conflict with virtual multiblog.

  6. @hartley_h: Thanks for the hint on what might be the issue.

    I'll dig into it this weekend and work out what the incompatibility is.

  7. @mercime
    Volunteer Moderator
    Posted 5 years ago #

    First of all, thank you WordPress.org Community for the Health Check plugin :-)

    I admit to missing the results under Plugin header as well after activating the plugin :-) Might I suggest changing Readme text while info is not yet generated in Tools menu for this line:
    Once it has checked the versions it will feed back the results.
    to something like
    Once it has checked the versions it will feed back the results under the header of the Plugins page.

  8. @mercime: Great idea. Thanks for the improved copy

    I'm going to include a screenshot too.

    @hartley_h: I've had a play with the Virtual Multiblog plugin and set it up locally. I can always see the message even using that. I setup a number of sites and all worked fine using WordPress 3.0.1 and Virtual Multiblog 2.6.2. What other plugins are you running?

  9. @mercime
    Volunteer Moderator
    Posted 5 years ago #

    @westi - thank you for updating the readme and adding the screenshot :-)

  10. hartley_h
    Posted 5 years ago #

    Sorry to be so long getting back to this. I've tried deactivating and then moving all plugins out of the plugins directory (except health-check, of course). No change -- there remains no notification on activation of the plugin.

    Putting some print statements in the health-check.php file, it appears that in function action_plugins_loaded(), get_transient('health-check-version-test') is returning false so add_action('admin_notices'...) is not running. Is that intended?

Topic Closed

This topic has been closed to new replies.

About this Topic