WordPress.org

Forums

Header Image Slider
[resolved] Failed to load given url... (8 posts)

  1. superpotion
    Member
    Posted 4 years ago #

    Slideshow wasn't showing. Checked source in Firebug:

    <div id="featured-image">
    	<a href="http://arcfyre.potion.co.za/">
    		<img width="770" src="http://nivo-uploaded-image">
    	</a>
    	...

    The url in the img tag is clearly not right.
    FYI. I'm using Twenty Eleven with a child theme.

    http://wordpress.org/extend/plugins/header-image-slider/

  2. superpotion
    Member
    Posted 4 years ago #

    Sorry, made a typo with the boom_header_image() template tag.

    But it's not working yet, there's something else going on. I get the loading.gif but no images. Page Info -> Media in Firefox shows all 8 slider images. I guess there may be a JS function dupe. Here's the script load order from the page source:

    wp-includes/js/l10n.js?ver=20101110
    wp-includes/js/jquery/jquery.js?ver=1.6.1
    wp-content/plugins/sidebar-login/js/blockui.js?ver=1.0
    wp-content/plugins/sidebar-login/js/sidebar-login.js?ver=1.0
    wp-content/plugins/header-image-slider/nivo-slider/jquery.nivo.slider.pack.js?ver=2.6
    wp-includes/js/jquery/ui.core.js?ver=1.8.12
    wp-includes/js/jquery/ui.widget.js?ver=1.8.12
    wp-content/plugins/custom-contact-forms/js/jquery.ui.datepicker.js?ver=3.2.1
    wp-content/plugins/custom-contact-forms/js/custom-contact-forms-datepicker.js?ver=3.2.1
    wp-content/plugins/custom-contact-forms/js/jquery.tools.min.js?ver=3.2.1
    wp-content/plugins/custom-contact-forms/js/custom-contact-forms.js?ver=3.2.1
    http://maps.google.com/maps?file=api&v=2&hl=en&key=ABQIAAAAk3P3VAxej726sl8z3DXB4BRjuWXyL-9ayEdE-0QiRyMEplYLPRSBHtCqtC4n1nZ39v6rvjEb7O87Ag&sensor=false&ver=2
    wp-content/plugins/wp-geo/js/tooltip.js?ver=1.0
    wp-content/plugins/wp-geo/js/wp-geo.js?ver=1.0
  3. superpotion
    Member
    Posted 4 years ago #

    Decided to try with a freshly installed WP to see where it breaks.

    First problem: Header Image Slider is trying to find the packaged theme images in .../images/headers/ folder of the child theme instead of the parent theme. It works fine with uploaded images.

    I've installed all the plugins, and the slider fails...

    Conflict with Custom Contact Forms plugin.

    Any ideas on how to fix this easily?

    Thanks for an excellent plugin.

  4. shazdeh
    Member
    Plugin Author

    Posted 4 years ago #

    I think there's a problem wwith Custom Contact Forms data picker's script. That script file fails and stops execution of other scripts in the page. Could you please post the console messages?
    And yeah, there's a bug with default images and child themes. The next version is ready in the next few day, it'll fix it. Sorry about that.

  5. superpotion
    Member
    Posted 4 years ago #

    Console Error Messages (only 1):
    jQuery("div.headerSlider").nivoSlider is not a function

  6. shazdeh
    Member
    Plugin Author

    Posted 4 years ago #

    Are you working on a live website? Could you provide the link?
    Also, have you updated the plugin? Goto Header options and reselect 'slider'. Hopefully that fixes it.

  7. superpotion
    Member
    Posted 4 years ago #

    Thanks Shazdeh, I've updated the plugin and re-selected 'slider', but still using the boom_header_image() template tag.

    The development site is here. Custom Contact Forms plugin is enabled so you can see the symptom.

    Thanks, Denis.

  8. superpotion
    Member
    Posted 4 years ago #

    We're off the original topic of this thread. Have restarted in another thread.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Header Image Slider
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic