WordPress.org

Support

Support » Plugins and Hacks » WP Defer Loading » [Resolved] Plugin has no valid header?

[Resolved] Plugin has no valid header?

  • Something wrong with the header?
    after installing and activating, i got an error message something like that “plugin has no valid header” and shows on at the top of the wordpress blog

    ‘ar elementjquery = document.createElement(“script”);function helperjquery(){ var elementjquery_migrate = document.createElement(“script”); elementjquery_migrate.src =…’

    will there be an update?

    http://wordpress.org/plugins/wp-defer-loading/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author bassjobsen

    @bassjobsen

    Which version of WP do you use?
    I will try to fix this asap. I can’t reproduce your error at the moment.
    Thanks for posting.

    3rd Eye

    @3rdeyeguam

    I think he means that header error happens after you install via the Dashboard installer. I got it too, after you click install it brings you to a page that says Activate | Return to plugins installer

    If you click Activate it errors. If you go back to the plugin listing and activate it does not, but then it also prints an error in the dashbooard header (for me):

    var element = document.createElement("script"); element.appendChild( document.createTextNode( "var wpscstScriptParams = {\"wpscstPluginsUrl\":\"http:\\/\\/thirdeyeguam.com\\/wp-content\\/plugins\"};" ) );document.body.appendChild(element); var element = document.createElement("script"); element.appendChild( document.createTextNode( "var WordfenceAdminVars = {\"ajaxURL\":\"http:\\/\\/thirdeyeguam.com\\/wp-admin\\/admin-ajax.php\",\"firstNonce\":\"fa48a67d40\",\"siteBaseURL\":\"http:\\/\\/thirdeyeguam.com\\/\",\"debugOn\":\"0\",\"actUpdateInterval\":\"2000\",\"tourClosed\":\"1\"};" ) );document.body.appendChild(element);

    I disabled it for now, but thanks for the contribution. I’m using WP 3.7.1

    Plugin Author bassjobsen

    @bassjobsen

    @3rdeyeguam thank you for responding on this issue.

    I test the latest version with 3.7.1 and didn’t found the errors you mention. Could you make sure you use the latest version. I have update the version number to 1.0.1 hope this help.

    I expected https://github.com/bassjobsen/wp-defer-loading/commit/ccc8543bb25efae21eea8c92885b2c364d4d2179 shlould have fix fix this as described here: https://github.com/bassjobsen/wp-defer-loading/issues/7

    Am I allowed to get in this topic.

    I have installed mystile on 3.7.1 and then try to install woodojo with woocommerce and everything fails. I get the remark Plugin has no valid header. I tried and tried spent 4 hrs. With clean installs different url’s . It does not work can anybody help me? Thanks a million!

    esmi

    @esmi

    Forum Moderator

    @jalu73: If you require assistance then, as per the Forum Welcome, please post your own topic.

    Plugin Author bassjobsen

    @bassjobsen

    @jalu73 thanks for your message.

    When i check the source code of http://demo2.woothemes.com/mystile/, i find:

    <script type="text/javascript">
    	jQuery(document).ready(function(){
    
    		jQuery('ul#stylelinks li').click(function(){

    etc.

    At the moment i don’t think the Mystile is ready for defer loading. (i’m not sure this also cause the “Plugin has no valid header” error). Also read: http://bassjobsen.weblogs.fm/wordpress-development-properly-load-javascript-set-dependency/

    Does everything work without the defer loading plugin?
    Are you bound by the Mystile plugin at this moment? Are just starting?

    Plugin Author bassjobsen

    @bassjobsen

    @jalu73 i build a test install at http://mystile.w3masters.nl/ (not sure if this domain resolves for you yet).

    Using:

    Mystile 1.2.17
    WooFramework 5.5.5
    WooCommerce 2.0.20
    WooDojo Version 1.5.4
    WP Defer Loading 1.0.2

    I didn’t found the problems you mention. I found the theme have some undefined variables, like: Undefined index: woo_homepage_banner in /home/mystile/domains/mystile.w3masters.nl/public_html/wp-content/themes/mystile/index.php on line 21 when running in the debug mode.
    I also didn’t found the javascript code from my previous post.

    What webserver do you use? Earlier we found difference between Apache and nginx. I have test on apache with php PHP 5.3.18 (cli)

    @esmi. Thanks for guiding me in right direction!!

    @bas Bas, thanks ever so much for your quick respons and work. This is why i love wordpress. When needed Help comes from all directions. Super!

    Now I found what the problem was. It was my hosting partner. He resetted rights (i’m a bit in the dark to be honest) something with DNS and put all my domains on the shared server. Everything is ok now. So thanks again for your help!!!

    grt Louis

    Plugin Author bassjobsen

    @bassjobsen

    close

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] Plugin has no valid header?’ is closed to new replies.
Skip to toolbar