Support » Plugin: Custom Fonts » Plugin has messed up metaboxes in gutenberg editor

  • Resolved casfaulds

    (@casfaulds)


    After installing this plugin, the two metaboxes that are enabled in my gutenberg editor now appear overlaid over the editor, so it’s not possible to see the full editor, nor is the functionality of the metaboxes (one for Mashshare and one for The SEO Framework) fully accessible.

    I tested to see whether this plugin was definitely the cause by deactivating it and the metaboxes returned to normal. I would really love to use this plugin as it integrates well with my theme (Astra) and page builder (Beaver Builder with ultimate add ons for BB), but I obviously can’t if it messes up my editor.

    I’m happy to communicate privately to provide you with login details to my site if you need to see what is happening.

Viewing 6 replies - 1 through 6 (of 6 total)
  • I’m going to mark this as resolved since I decided to just use font-face in my child theme. This is no reflection on Brainstorm Force’s support. They’re always great! I just decided that I could do it myself and have one less plugin.

    deepakl

    (@deepakl)

    Hi @casfaulds ,

    If you wish we can look into this and see if the issue is from our plugin. But if you have already decided your way, then now worries. Just in case your need any help in future then do post your issue related to the product and we would surely help you out.

    David Wang

    (@blogjunkie)

    I had a similar issue and realized that it was caused by a body { height: 100% } CSS rule. Gutenberg converts it to .editor-writing-flow { height: 100%; }

    To fix it, I added this CSS to my wp_head

    .editor-writing-flow {
    	height: fit-content !important;
    }

    Hope this helps you guys at BSF fix the problem 🙂

    deepakl

    (@deepakl)

    Hi @blogjunkie & @casfaulds ,

    I tried to replicate the issue but I am not able to replicate the issue on my side, everything seems fine on our side.

    Would it be possible for you to share the screenshot of the issue related to metabox or Gutenberg Editor that are been disturbed with Custom Font plugin?

    Hi, I can replicate the problem – it’s very simple, the problem is that in the wp-admin backend, the font declarations from the plugin are output before the opening <!DOCTYPE html> declaration, putting the browser into quirks mode, which does funny things to the CSS of the Gutenberg metaboxes. Would be great if that could be fixed.

    PS: for testing, you need a long article and something that creates extra metaboxes, such as Yoast, enabled.

    • This reply was modified 9 months, 2 weeks ago by .

    Hi @hrabbach,

    We have fixed this issue and soon we will release an update.

    Regards,
    Uttam

    • This reply was modified 9 months, 1 week ago by uttam007.
Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Plugin has messed up metaboxes in gutenberg editor’ is closed to new replies.