Support » Plugin: UpdraftPlus WordPress Backup Plugin » Plugin hanging and preventing use of rest of WordPress

  • Resolved robinwyatt

    (@robinwyatt)


    Hi there,

    I have the latest version of UpdraftPlus. Every time I’ve tried to do a backup today, the plugin has hung and at the same time it has made the rest of my WordPress non-responsive. Only when I asked my host to kill the process did WordPress become responsive. I then deactivated and reactivated the plugin; again, the problem repeated. I have tried searching the forum, but I’ve not found any suggested fixes for this exact problem. I also tried getting a bug report from the plugin, but this failed as well. What can I do?

    Thanks so much in advance!

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Contributor DNutbourne

    (@dnutbourne)

    Hi,

    Please could you send us a copy of the latest backup log?
    This can be found in the ‘wp-content/updraft’ directory of the site via FTP or your hosting’s filemanager.

    The contents will be too long to post here directly, but you can use an online service such as Pastebin, and post the link here.

    Hi,

    This happened twice today, so you can get both logs here.

    Many thanks!

    This happened to 2 of my sites today as well. I updated to version 1.12.40 and the site’s dashboard won’t load anymore. If I rename the updraftplus folder via ftp, the dashboard comes back. The site’s front-end did work however even with the plugin enabled.

    Plugin Contributor DNutbourne

    (@dnutbourne)

    Hi @robinwyatt,

    The logs show a very low read/write rate, which is preventing the backup from completing.
    This indicates that the server is either overloaded, or has a very low I/O limit.
    Please could you ask your hosts to check the load and I/O rate on the server?

    @ravishi this sounds like the update failed. Please could you reinstall from a fresh copy? If the problem persists, please open a new thread.

    Hi there, thanks for this. I checked with my host, and was told that it’s set to 1 Mbps. Apparently, it can’t be raised unless I move to VPS hosting. The plugin was always working fine for me before, though. Would you expect 1 Mbps to be enough normally or not?

    Plugin Contributor DNutbourne

    (@dnutbourne)

    Hi,

    1Mbps is fairly low. Because this limit is being split between UpdraftPlus and any other processes on the site and as your site has grown, UpdraftPlus is not able to create the backups in the time allowed.

    I would recommend reducing the backup archive split limit (through the ‘Split archives every’ option in the expert settings section of the Settings tab) to 25MB. This will reduce the batch size of data that is processed at once.
    Could you also ask your hosts if the maximum execution time for the site can be raised as high as possible?

    This will give the best chance of backups completing.

    Thank you.

    My hosts responded, saying “The max_execution_time set to 600 which is the highest. Normally the shared servers would have 30 sec, so 600 should be more than enough.”

    I have reduced the backup archive split limit to 25MB, as you suggested. I’ll see how this goes, and revert back here should there be any further problems.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Plugin hanging and preventing use of rest of WordPress’ is closed to new replies.