Support » Plugins and Hacks » [Plugin: Haiku minimalist audio player] Error

[Plugin: Haiku minimalist audio player] Error

  • I get this error:

    jPlayer 1.2.0 : id='haiku-player1' : Error!
    Problem with Flash component.
    Check the swfPath points at the Jplayer.swf path.
    swfPath = http://www.munirhossn.com/wp-content/plugins/haiku-minimalist-audio-player/js/
    url: http://www.munirhossn.com/wp-content/plugins/haiku-minimalist-audio-player/js/Jplayer.swf
    Error: a._getMovie().fl_setFile_mp3 is not a function

    Any idea?


Viewing 15 replies - 1 through 15 (of 29 total)
  • I get the same error.

    Ever get a resolution?

    Same error, but not with all themes. I think it depends on the theme, or the scripts used by the theme.
    Anyway, I don’t understand why Haiku player needs flash. Isn’t it an HTML5 player? It could be work only with javascript and css.

    Hmm… there is no error message if Firebug is disabled.

    I have 1 person who experiences this error on my site when all other users don’t have a problem. I wish that I could fix this error for him but I don’t know how. Any Ideas?

    Plugin Author Dalton Rooney


    This error is often caused by Firebug. You might also see it if you’ve got a Flashblocker running or if you have javascript errors in your theme.

    The plugin defaults to Flash and falls back to HTML5 on browsers that don’t support Flash like Mobile Safari. HTML5 audio support still isn’t universal (no MP3 in Firefox, not at all in older versions of IE) so Flash is still in use by default. The two important things for me in designing this plugin: 1) works on iOS and 2) clean design that can easily be modified with HTML & CSS.

    I ran into the same issue when using Haiku inside Fancybox. Disabling Firebug and restarting Firefox works the first time that I access the player. But when I close the Fancybox link and re-open it, that error reappears.

    I’m using Firefox 10.0.2. I do not run in to this issue when testing in both Safari and Chrome.

    Running Firefox 10.0.2 and still had the error even after disabling Firebug. Re-enabled and disabled AdBlock Plus 2.0.3 and all is well on the Mac side (haven’t tested on the PC).

    Have you tried to play the track multiple times in one page view? That’s where I run in to issues…

    Yes, I did as well. Once AdBlock was gone all was weel with the world. I’ve downloaded the Adblock Diagnostics to see what it shows, but haven’t looked further yet.

    What platform are you on? What’s your link? Want to try mine and see if you’re getting problems?


    Plugin Author Dalton Rooney


    Please let me know if you find out anything about AdBlock. I’ll do some testing too. I would love to find a workaround if this could with plugin compatibility.


    Plugin Author Dalton Rooney


    I have tested the latest version of FFX & Adblock on all of our demo pages with no problems. I wonder if this has to do with particular filter lists or URL matches on the media files themselves?

    If either of you can upload the MP3 files to another site, does the behavior change?


    Unfortunately I cannot disclose the site URL, but this is what I’m working with:

    • WP 3.3.1
    • Mycorptheme with minor tweaks (multiple custom post types, page templates, etc.)

    I’ve uploaded an MP3 file to my personal website and still receive an error message. But this part of the message – “Error: ***** is not a function” – is different than the error that I receive when the MP3 file is on the site that I’m working on.

    MP3 file on personal site
    Error 01

    MP3 file on current site
    Error 02

    Kyhams: I was getting the same error you’re getting on the personal site (same as the graphic at the top of this thread).

    Dalton & Kyams: I apologize. After further testing it wasn’t AdBlock. It seems that the error (for me) appears almost never on the initial page load. On refreshing the page it rarely happens the second refresh, more frequently on the third, and always by the forth refresh.

    After looking more at the actual error and knowing that the Google site translator widget uses Flash I tried that route. Removed the widget. I’ve loaded, refreshed, restarted, cleared the cache, didn’t clear the cache, everything I can think of many many times. Now I’m not getting an error.

    Really never, this time. (Sorry about that!)

    Are either of you using the Google Translate widget? Any other flash bits on your page?


    Plugin Author Dalton Rooney


    Hi Nick,
    What other browsers have you tested in? Just curious to know if this was happening in other browsers or just Firefox. (Firefox has always been a little bit of a problem with this plugin, since it doesn’t support HTML5 MP3 natively that’s why we need to enable Flash fallback in the player)

    I personally don’t use any Flash add ons on any of my sites, maybe that’s why I’ve almost never come across this error in my testing.

    I also think if you’ve got any other heavy javascript slowing down the page it could cause a problem. I always start in the default theme, no plugins, and work my way up one by one until I find which one is causing the problem.


    I am not using Google Translate.

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘[Plugin: Haiku minimalist audio player] Error’ is closed to new replies.