Support » Plugins and Hacks » [Resolved] [Plugin: GTS Translation Plugin] Machine translated pages give 404

[Resolved] [Plugin: GTS Translation Plugin] Machine translated pages give 404

  • Hello,

    I´ve just started using the plugin on my website http://www.perfectperu.info

    When I update my pages I get emails confirming that the page has been translated. However, when I try to look at this page I get 404 errors stating the pages are not availabe.

    Do you have to review the machine translated pages before they are visible on the website? I tried that with a few page’s but they don’t appear as either.

    I hope someone can help me with this problem.

    Thanks in advance!


Viewing 6 replies - 1 through 6 (of 6 total)
  • Some small additions:

    the posts don’t show up in manage posts in the dashboard as well. How long does it take for a translation to be available normally?

    Plugin Contributor sergeyvlasov


    Hello onlineous!

    My name is Sergey, and I’m trying to provide support to the plugin in my spare time 😉

    Can you tell me please, whether your site is accepting machine translated content? It’s a check box near the bottom of ‘GTS Settings’ page.
    Additionally, try to check out whether there are posts waiting for approval. In order to do this, go to ‘Manage Posts’ page and click the link near the top of the page, with ‘GTS Website’ anchor text.

    Tell me please what do you see and any additional questions you have!

    Yes the ‘Display machine-translated content?’ is checked.

    I don’t have posts, I only have pages.

    Normally when I make a page it shows up on the GTS website with status ‘Machine Translated’. When I hit, ‘Check out’ on the right, this box changes to ‘Review’. When I hit review I get an editor. When edited it goes to status ‘Reviewed’. However, the reviewed posts don’t show up translated on the website.

    This link should go to a translated (deutsch/german) website:
    Strangely enough it ends up on the english variant. When I try to use the widget to translate to german I get a 404.

    Found out anything yet?

    Plugin Author davegrun


    Dear onlineous!

    We have forwarded this issue to our developers. We will let you know once it is resolved.

    I found the sources of the problem. I had the ‘local landing pages’ plugin enabled.
    I found out that was the problem when I tried to autotranslate using google translate. I got a redirection error and that brought me to ‘local landing pages’. I disabled the plugin and the translations work now!

    Thanks for trying to help me!

    Best regards,

    Jaco Hollebrandse

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] [Plugin: GTS Translation Plugin] Machine translated pages give 404’ is closed to new replies.