WordPress.org

Forums

GTranslate
[resolved] update not working (6 posts)

  1. revrockrohr
    Member
    Posted 4 years ago #

    The Gtranslate update for the updated WordPress 3.0.2 does NOT work!

  2. ewendland
    Member
    Posted 4 years ago #

    This is because of the URL used in the update form. At least if you use "FORCE_SSL_ADMIN". You can fix this by changing line 263 in gtranslage.php from:

    <form id="gtranslate" name="form1" method="post" action="<?php echo get_admin_url() . '/options-general.php?page=gtranslate_options' ?>">

    to

    <form id="gtranslate" name="form1" method="post" action="<?php echo get_admin_url() . '/options-general.php?page=gtranslate_options' ?>">

    I am hoping this change can get into the next release of gtranslate? It is a nice plugin!

  3. ewendland
    Member
    Posted 4 years ago #

    Oops, my "before" case is the same as my "after". Basically the diff is the current version of the plugin uses get_option('site_url') instead of get_admin_url() which means it will do http instead of https...

  4. kbellis
    Member
    Posted 4 years ago #

    The posts above do not state which release of GTranslate is discussed.

    GTranslate 1.0.13 is not working in WP3.1 either.

    It downloads, installs and seems at first to be configurable through settings... however, an unexpected behavior was observed: after adding two flags to the default set; Icelandic and Swedish, the flags appear above the Select Language pull down, but note immediately those two check boxes get cleared. This is a minor point.

    The major point is nothing else works; that is, there is no translation - at all - regardless of clicking on a flag or using the select language pull down.

    Searching completely through gtranslate.php for:

    <form id="gtranslate" name="form1" method="post" action="<?php echo get_admin_url() . '/options-general.php?page=gtranslate_options' ?>">

    comes up empty.

    However, at line 261 we find this:

    <form id="gtranslate" name="form1" method="post" action="<?php echo get_option('siteurl') . '/wp-admin/options-general.php?page=gtranslate_options' ?>">

    Please advise.

    Thanks.

    Kelly

    See GTranslate Forum for similar post

  5. revrockrohr
    Member
    Posted 4 years ago #

    Sorry I have not responded back to this. GTranslate is working with fine with WP 3.1 now. Thanks.

  6. kbellis
    Member
    Posted 4 years ago #

    Yes, the issue that I had been experiencing has been resolved, with much thanks to Edvard, and is discussed in greater detail in the GTranslate Forum linked above.

    Kind regards,

    Kelly

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • GTranslate
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags