WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Group Documents] Can't get it working with BP 1.5 RC1

[Plugin: Group Documents] Can't get it working with BP 1.5 RC1

  • Krokkodriljo
    Member

    @krokkodriljo

    Did anyone get this plugin working with BP 1.5 RC1?

    The tab option “Documents” is not showing on group pages and I’m guessing bp_core_new_subnav_item() or related functions have been changed.

    The admin option tab is there however, linking to /groups/[groupname]/admin/documents/

    I tried to manually enter /groups/[groupname]/documents/ but no luck… it’s a 404.

    Cheers,
    Johan

    http://wordpress.org/extend/plugins/buddypress-group-documents/

Viewing 15 replies - 1 through 15 (of 57 total)
  • jimmytortuga
    Member

    @jimmytortuga

    Confirm that. The “Documents” tab disappeared from my group pages when I updated to 1.5.

    The documents are still there, though, as I can access them through external links.

    From there, I can see the actual route is http://mysite.com/wp-content/uploads/group-documents/ and then a long string of numbers which I think is the file name assigned to it by GD. Unless you know what it is, you won´t be able to access them through your browser; but you might find them using this route in your ftp file manager.

    At any rate I hope GD is updated real soon, I just finished loading course material into my course´s group yesterday, and now its totally useless without the tab.

    Krokkodriljo
    Member

    @krokkodriljo

    I suppose the changes made to how the group menus are manipulated are explained here: http://bpdevel.wordpress.com/2011/09/05/manually-modifying-single-group-navigation-in-bp-1-5/

    Unfortunately, I don’t know php good enough to fix the plugin.

    Krokkodriljo
    Member

    @krokkodriljo

    I might have fixed it

    1. Open buddypress-group-documents/index.php
    2. Around line 248:

    Change:

    'parent_slug' => $bp->groups->slug,

    to:

    'parent_slug' => bp_get_current_group_slug(),

    3. Around line 259

    Change

    add_action( 'wp', 'bp_group_documents_setup_nav', 10 );

    To:

    add_action( 'bp_setup_nav', 'bp_group_documents_setup_nav', 10 );

    Krokkodriljo
    Member

    @krokkodriljo

    Okay, I managed to get the Document option showing in the group menu but uploading files doesn’t work.

    The form’s action path (set by $template->action_link) is incorrect.

    $template->action_link is defined here

    $this->action_link = get_bloginfo('url') . '/' . $bp->current_component . '/' . $bp->current_item . '/' . $bp->current_action . '/';

    …and “$bp->current_component” is incorrect. It says “groups” but I have changed the group slug like so:

    define( 'BP_GROUPS_SLUG', 'verksamhetsgrupper' );

    Suggestions?

    Krokkodriljo
    Member

    @krokkodriljo

    Upload works when I hard coded the URL.

    I also had to modify cssjs.php in order to enqueue the css and javascript files.

    Where are you @peter-anselmo, we need you!

    Plugin Author Peter Anselmo
    Member

    @peter-anselmo

    Okay, Fired up the 1.5, looking into it now.

    Plugin Author Peter Anselmo
    Member

    @peter-anselmo

    The Development Version has been updated with some changes. Anyone who knows what that means is welcome to give it a whirl. I hope to have a new release out soon.

    Cheers,
    Peter

    Plugin Author Peter Anselmo
    Member

    @peter-anselmo

    Just tagged 0.4.0 as Stable. Requires BP version 1.5. If you’re running an earlier version, don’t upgrade Group Docs.

    Cheers,
    PEter

    jimmytortuga
    Member

    @jimmytortuga

    Just tried v.0.4.0. The “documents” tab appears again – OK – but now the problem is that when I click on it, it says it can´t find the page http://mysite.com/groups/mygroup/documents/ : it just says “page not found”. Therefore, I STILL can´t see the uploaded documents or upload new documents. Please help…

    Plugin Author Peter Anselmo
    Member

    @peter-anselmo

    @jimmytortuga
    Oh Noes! If you can, could you send me an email to peter@studio66design.com? Good stuff to include would be your wordpress version, an example URL, and any customisations (such as slugs defined in bp-config.

    Cheers,
    Peter

    I’ve the same problem “page not found” on a fresh install wp 3.2.1 bp 1.5 and group documents 0.4

    I’m using private groups (for information)

    I’ve find why

    on bp 1.5 the community menu is not longer valid
    i’ve re-create it, and put forums, groups and users in subs menus

    your plugin don’t understand that, and the 404 error appear

    that’s all

    WebEndev
    Participant

    @munman

    I’ve the same problem “page not found” on a fresh install wp 3.2.1 bp 1.5 and group documents 0.4

    Same problem here

    I got the same problem aswell, on a fresh install, the documents tab shows up but the link doesnt work. 404. Did anyone solve this yet?

    For my case the problem was the permalink of User Groups page

    If you go in the buddypress menu and the page menu.

    In the User Groups section, check what is the selected page. After that, go in the page menu of wordpress and check the permalink of this page.

    My problem was
    http://bla-bla-bla/groups-2

    It must be for the plugin group document to work correctly
    http://bla-bla-bla/groups

Viewing 15 replies - 1 through 15 (of 57 total)
  • The topic ‘[Plugin: Group Documents] Can't get it working with BP 1.5 RC1’ is closed to new replies.