Support » Plugins and Hacks » [Plugin: Group Documents] 3.1 and BP 1.28 Admin Menu non accessible

[Plugin: Group Documents] 3.1 and BP 1.28 Admin Menu non accessible

  • Seems like the 3.1 network admin page change has hidden the config options for this.

    I can still upload files but for eg the new docx etc formats cant be uploaded

Viewing 13 replies - 1 through 13 (of 13 total)
  • changed admin_menu to network_admin_menu in index.php

    Now appears in admin menu and can create links

    Not tested all functions but think it’s okay just need to update my CSS



    Volunteer Moderator

    I recommend using this plugin instead. This is compatible with current WP and BP versions http://wordpress.org/extend/plugins/buddypress-docs/

    Plugin Author dennissmolek



    that plugin is for text only..

    I am interested in using BuddyPress Docs but the plugin page states that it requires BuddyPress 1.3 which isn’t yet available as a stable release.

    Is BuddyPress Docs suitable for use on a production BP 1.2.8 install with WP 3.1.2?

    I also read that there are plans to add a file upload facility to BuddyPress Docs. Is anyone working on this?

    You can use BuddyPress Docs with BP 1.2.8. Not every little feature is supported (doc counts in the tabs, for instance), but it is stable and quite usable on 1.2.x.

    I am working on an upload feature, but it won’t be available for some time. If anyone else starts working on it, they are more than welcome to contribute.

    That’s great. Many thanks for the info.


    Thanks for the great tip.

    However, in order for the “Save Settings” button to work on that page, I also had to change the form action in buddypress-group-documents/includes/admin.php line 72 from:

    to :


    Hi, I just tried to activate the bp group documents plugin on my wordpress site and got the following message about a fatal error:

    Plugin could not be activated because it triggered a fatal error.

    Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or ‘}’ in /hermes/web10/b2537/hy.secondlooks/wordpress/wp-content/plugins/buddypress-group-documents/include/classes.php on line 4

    Any help would be appreciated!



    Volunteer Moderator

    @benwin that error appears because your server is running PHP4. Suggest you upgrade to PHP5 as upcoming WP 3.2 will require PHP5.2

    Thanks so much, mercime! I will talk to my hosting service about upgrading to PHP5.

    Thanks @easywizard and @jvarn1 🙂 finally i get it worked 🙂

    i´m having big trouble with Group Documents
    followed some of this posts and got admin network panel menu item to show and save but still, after migration from 1.2.10 to 1.5 and 1.5.1 can´t get previous docs to show as activities (blank activity shows instead) or to upload new documents. Constant failure on upload.
    I´ve checked and my php version is 5.2 so that shouldn´t be the problem.
    Activity data is still stored in the DB for the previous uploads but doesn´t show.
    It does show the groups document list under the documents tab.
    Can anybody help on solving this?
    Thanks a lot,


    ok, one more thing…
    my site is in spanish so instead of groups/x/ in the url
    i´m using define ( ‘BP_GROUPS_SLUG’, ‘grupos’ );
    to get grupos/x/ in the url

    if i switch it back to groups i get the upload to work
    but still no content shows as activity
    just the description, nothing else

    sorry, once again… any ideas on how to fix this to get both things running again?

    activities showing and files uploading even when i use – define ( ‘BP_GROUPS_SLUG’, ‘grupos’ );

    i look forward to any reply that might help

    thanks a lot,


Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Plugin: Group Documents] 3.1 and BP 1.28 Admin Menu non accessible’ is closed to new replies.