WordPress.org

Support

Support » Plugins and Hacks » Gravity Forms Salesforce Add-on » [Resolved] [Plugin: Gravity Forms Salesforce Add-on] No settings for API version

[Resolved] [Plugin: Gravity Forms Salesforce Add-on] No settings for API version

  • Hey, I just tried setting up this plugin and for some reason on my client’s iPage server when I go to the Salesforce settings page it’s just blank where the settings should be. I don’t even see the “How to set up integration:” box.

    I have a duplicate copy of the exact same site on my testing server (not iPage) and on that one I can see the settings. Any idea why that might happen?

    P.S., On the server where I can see the settings, I get the following error above the list of feeds in the “Salesforce Feeds” page: Warning: extract() expects parameter 1 to be array, boolean given in …/wp-content/plugins/gravity-forms-salesforce/salesforce-api.php on line 536

    http://wordpress.org/extend/plugins/gravity-forms-salesforce/

Viewing 8 replies - 1 through 8 (of 8 total)
  • taropaa

    @taropaa

    I get the same error. Make sure to mark the plugin as not working so that the developer knows.

    Plugin Contributor Zack Katz

    @katzwebdesign

    This is fixed in 2.1.1.

    Please make sure to rate the plugin one you’ve got it set up. Thanks!

    taropaa

    @taropaa

    Thanks Zack, I just updated the plugin and I still have the same issue. I am using the latest wordpress multisite.

    Thanks, A

    Plugin Contributor Zack Katz

    @katzwebdesign

    Are you positive?

    Please try deleting the plugin and re-installing it; it should not be possible to have the same issue.

    taropaa

    @taropaa

    Hi Zack,

    Thanks for the reply, I have tried it, but I got the same result. I will look through my logs and try to find some debug info for it.

    It is strange, the settings page comes up blank across all sites on the network.

    Plugin Contributor Zack Katz

    @katzwebdesign

    Do you have the Members plugin installed?

    heavymark

    @heavymark

    Same issue here.

    The site is installed locally and works fine. An exact copy of the site on a DV server however the settings page is blank. Screenshot here: http://cl.ly/LKos.

    And yes, I like the others reporting the problem am using a fresh copy of 2.1.1.

    To note, I looked in my local computer’s error logs and that last time it showed, “[08-Nov-2012 21:10:48 UTC] PHP Warning: extract() expects parameter 1 to be array, boolean given in /Users/myname/Sites/example.org/app/wp-content/plugins/gravity-forms-salesforce/salesforce-api.php on line 536”

    Was on Nov 8th. So while the 2.1.1 may have fixed that one warning, the bug that prevents users from accessing settings on some live servers (such as mine and the other posters still exists).

    And I do not have the members plugin installed.

    Hi. I am having the same issue with the API plugin described here. The site is running WordPress 3.5.1 and Gravity Salesforce API plugin is 2.2.4.4.

    The API settings are blank. Oddly, the web-to-lead works fine. We run Salesforce Enterprise Edition, though I don’t think that matters since I just get a blank screen for settings.

    I deleted and reinstalled the plugins. No joy. See image here

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] [Plugin: Gravity Forms Salesforce Add-on] No settings for API version’ is closed to new replies.
Skip to toolbar