WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Gravity Forms Salesforce Add-on] Lookup and Master-Detail fields missing

[Resolved] [Plugin: Gravity Forms Salesforce Add-on] Lookup and Master-Detail fields missing

  • In the Enterprise edition, we’ve created a custom object. I can pull this object in fine, but when trying to map form fields to list fields, lookup fields and master-detail fields do not come through. Since these are marked as required in Salesforce, the mapping fails every time.

    Is there any way to get these to show in the plugin?

    Edit: latest version of WP and the plugin

    http://wordpress.org/extend/plugins/gravity-forms-salesforce/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Yes, this. The fields would either have to be populated by a hidden field, or if you’re sending out an email that links to your form, you could fill the form with a URL parameter that’s dynamically generated with the right ID by your email program.

    Wanted to post an update – there is an undocumented filter that hides reference types on line 1147 in salesforce-api.php.

    if($var[‘type’] === ‘reference’ && apply_filters(‘gf_salesforce_skip_reference_types’, true)) { continue; }

    Needed filter in functions.php is:
    add_filter(‘gf_salesforce_skip_reference_types’, ‘__return_false’);

    Whoops! Forgot to mark this as resolved!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] [Plugin: Gravity Forms Salesforce Add-on] Lookup and Master-Detail fields missing’ is closed to new replies.