Support » Plugin: Gravity Forms Salesforce Add-on » [Plugin: Gravity Forms Salesforce Add-on] Gravity Forms Salesforce Add-On not showing in Advanced fr

  • Resolved james@twenty26.co.uk

    (@jamestwenty26couk)


    I’ve got the Salesforce Gravity plug in working on a couple of other sites but this one (developer license of gravity), I’ve installed the latest version of both gravity forms and the Salesforce plugin, I’ve tried in all browsers, It’s connected to my salesforce org (green tick), I’ve got no errors….. But in the Advanced form settings there’s no Salesforce option?

    Can anyone tell me what I might be doing wrong?

    http://wordpress.org/extend/plugins/gravity-forms-salesforce/

Viewing 15 replies - 1 through 15 (of 21 total)
  • Scott Winterroth

    (@countrymusicchicago)

    I’m having the same problem. Not showing up in the advanced menu. Might try an older version of GF.

    Yeah, for some reason this doesn’t work with v1.6.3. I downgraded to 1.5.3 and it worked just fine.

    I had the same problem. Inspected the page and found that there was a JS error in the tooltip added to the Advanced tab on the form settings.

    Traced that back to a line in the Gravity Forms plugin’s tooltips.php file, where HTML single-quote vs. double-quote fun was breaking tooltips added by GF add ons.

    I’m submitting a patch to the GF developers. In the mean time, if you want to try the patch yourself see https://gist.github.com/1926684 for the patch. The only line that is different from GF is line 148.

    That, at the least, restores the option for me.

    YMMV,

    MSM

    There is the possibility that my patch to GF might break other GF add ons that also add options to the Advanced settings tab if they don’t use the right quoting around HTML attributes.

    If that turns out to be the case, here is a patch for the Salesforce add on that also brings back the option: https://gist.github.com/1926853

    This is probably a safer patch. (Oddly, the only change is on line 148 of that file as well.)

    I’ll submit this patch to the add on developer. It looks like GF and the add on developers need to agree on single- vs. double-quoting around HTML element attributes.

    Also, as far as I can tell, though this option was missing from the Advanced tab, if you had forms that were integrated with Salesforce previously, they remain so and still deliver the form data to Salesforce.

    MSM

    Also, don’t apply both patches at once. Pick one or the other.

    MSM

    Hi All
    Thanks so much for all your feedback. I tried MSM’s patches but couldn’t get this to work. I’m only semi tech and not sure if I did anything wrong? Anyway I eventually fixed it by reverting to a previous release of GF 1.6.2 and the Salesforce option is back and I’m connected again.
    Thanks again
    James

    If you applied both patches, you’d just be causing the break again.

    I confirmed with the GF developers that my first patch to GF would probably break other GF add ons. If you applied it, you should revert back to the shipped version. The GF developers are going to amend their developer documentation to indicate proper attribute quote style for add ons.

    So, in the mean time, only apply this patch to the latest version of the Salesforce add on plugin, replacing it’s salesforce.php file: https://gist.github.com/1926853

    MSM

    Plugin Contributor Zack Katz

    (@katzwebdesign)

    Just updated the code. Thank you @msmprojects – I appreciate it!

    This is fixed in Version 1.1.3.

    Hey, I’ve just downloaded the plugin and I can’t see the checkbook on the advanced setting tab.
    Also tried the patch offered above and still nothing.
    Would appreciate ant thought
    thanks a lot!

    I’ve resolved the issue above by removing the following line:

    add_filter(‘gform_tooltips’, array(‘GFSalesforce’, ‘add_form_option_tooltip’));

    now i was able to mark the box but no data is passing to salesforce,
    did i break anything by removing this line?

    Actually, folks, there’s no need to apply the patch to the Salesforce add on any more, as Mr. Katz has released an update to the plugin that includes it.

    Noted in the Gist.

    MSM

    I’ve updated my Gravity Force and the Salesforce add on and still cannot see the Salesforce check box in the advance menu

    Plugin Contributor Zack Katz

    (@katzwebdesign)

    Try using Chrome, Firefox or Safari browsers and let me know if the issue is still happening.

    I am using Chrome on a mac, using Gravity Forms Developer Edition version 1.6.3.2 and the option to enable salesforce is not showing in the advanced area and I installed the latest version of the SF plugin.

    Ideas?

    Zack, I tried using Chrome and Firefox browsers and still couldn’t get it to work. Any thoughts?

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘[Plugin: Gravity Forms Salesforce Add-on] Gravity Forms Salesforce Add-On not showing in Advanced fr’ is closed to new replies.