WordPress.org

Forums

Gravity Forms Salesforce Add-on
[resolved] Gravity Forms Salesforce Add-On not showing in Advanced fr (22 posts)

  1. james@twenty26.co.uk
    Member
    Posted 3 years ago #

    I've got the Salesforce Gravity plug in working on a couple of other sites but this one (developer license of gravity), I've installed the latest version of both gravity forms and the Salesforce plugin, I've tried in all browsers, It's connected to my salesforce org (green tick), I've got no errors..... But in the Advanced form settings there's no Salesforce option?

    Can anyone tell me what I might be doing wrong?

    http://wordpress.org/extend/plugins/gravity-forms-salesforce/

  2. Scott Winterroth
    Member
    Posted 3 years ago #

    I'm having the same problem. Not showing up in the advanced menu. Might try an older version of GF.

  3. brianfryer
    Member
    Posted 3 years ago #

    Yeah, for some reason this doesn't work with v1.6.3. I downgraded to 1.5.3 and it worked just fine.

  4. msmprojects
    Member
    Posted 3 years ago #

    I had the same problem. Inspected the page and found that there was a JS error in the tooltip added to the Advanced tab on the form settings.

    Traced that back to a line in the Gravity Forms plugin's tooltips.php file, where HTML single-quote vs. double-quote fun was breaking tooltips added by GF add ons.

    I'm submitting a patch to the GF developers. In the mean time, if you want to try the patch yourself see https://gist.github.com/1926684 for the patch. The only line that is different from GF is line 148.

    That, at the least, restores the option for me.

    YMMV,

    MSM

  5. msmprojects
    Member
    Posted 3 years ago #

    There is the possibility that my patch to GF might break other GF add ons that also add options to the Advanced settings tab if they don't use the right quoting around HTML attributes.

    If that turns out to be the case, here is a patch for the Salesforce add on that also brings back the option: https://gist.github.com/1926853

    This is probably a safer patch. (Oddly, the only change is on line 148 of that file as well.)

    I'll submit this patch to the add on developer. It looks like GF and the add on developers need to agree on single- vs. double-quoting around HTML element attributes.

    Also, as far as I can tell, though this option was missing from the Advanced tab, if you had forms that were integrated with Salesforce previously, they remain so and still deliver the form data to Salesforce.

    MSM

  6. msmprojects
    Member
    Posted 3 years ago #

    Also, don't apply both patches at once. Pick one or the other.

    MSM

  7. james@twenty26.co.uk
    Member
    Posted 3 years ago #

    Hi All
    Thanks so much for all your feedback. I tried MSM's patches but couldn't get this to work. I'm only semi tech and not sure if I did anything wrong? Anyway I eventually fixed it by reverting to a previous release of GF 1.6.2 and the Salesforce option is back and I'm connected again.
    Thanks again
    James

  8. msmprojects
    Member
    Posted 3 years ago #

    If you applied both patches, you'd just be causing the break again.

    I confirmed with the GF developers that my first patch to GF would probably break other GF add ons. If you applied it, you should revert back to the shipped version. The GF developers are going to amend their developer documentation to indicate proper attribute quote style for add ons.

    So, in the mean time, only apply this patch to the latest version of the Salesforce add on plugin, replacing it's salesforce.php file: https://gist.github.com/1926853

    MSM

  9. Zack Katz
    Member
    Plugin Author

    Posted 3 years ago #

    Just updated the code. Thank you @msmprojects - I appreciate it!

    This is fixed in Version 1.1.3.

  10. intigo
    Member
    Posted 3 years ago #

    Hey, I've just downloaded the plugin and I can't see the checkbook on the advanced setting tab.
    Also tried the patch offered above and still nothing.
    Would appreciate ant thought
    thanks a lot!

  11. intigo
    Member
    Posted 3 years ago #

    I've resolved the issue above by removing the following line:

    add_filter('gform_tooltips', array('GFSalesforce', 'add_form_option_tooltip'));

    now i was able to mark the box but no data is passing to salesforce,
    did i break anything by removing this line?

  12. msmprojects
    Member
    Posted 3 years ago #

    Actually, folks, there's no need to apply the patch to the Salesforce add on any more, as Mr. Katz has released an update to the plugin that includes it.

    Noted in the Gist.

    MSM

  13. katherine.garner
    Member
    Posted 3 years ago #

    I've updated my Gravity Force and the Salesforce add on and still cannot see the Salesforce check box in the advance menu

  14. Zack Katz
    Member
    Plugin Author

    Posted 3 years ago #

    Try using Chrome, Firefox or Safari browsers and let me know if the issue is still happening.

  15. chrisamacdonald
    Member
    Posted 3 years ago #

    I am using Chrome on a mac, using Gravity Forms Developer Edition version 1.6.3.2 and the option to enable salesforce is not showing in the advanced area and I installed the latest version of the SF plugin.

    Ideas?

  16. katherine.garner
    Member
    Posted 3 years ago #

    Zack, I tried using Chrome and Firefox browsers and still couldn't get it to work. Any thoughts?

  17. lisalisaallen
    Member
    Posted 2 years ago #

    Hi - having the same issue - I am using chrome on a mac - Gravity Forms 1.4.2 - the option to enable salesforce is not showing in the advanced area - also Salesforce is not displaying under the forms menu - any ideas would be appreciated -

  18. Marek_Kozlowski
    Member
    Posted 2 years ago #

    @ZACK

    I'm using Gravity Forms v1.6.4.5, WP 3.3.1 and GF SF Add on v1.1.3

    I don't see the option to select it in Advanced Tab, nor is it displaying under the forms menu (same as previous poster).

    Your assistance would be MOST appreciated.
    And thanks in advance... waiting with abated breath :-)

  19. lisalisaallen
    Member
    Posted 2 years ago #

    indeed - I really need to use this plug-in!

  20. marnafriedman
    Member
    Posted 2 years ago #

    Having the same problem as @ZACK, except that I am upgraded to WP 3.4, Gravity Forms Version 1.6.4.5.4 and GF SF Add-on Version 1.1.3.

  21. ross.edman
    Member
    Posted 2 years ago #

    I am having the same issue as well. I am using Gravity Forms 1.6.2.1.1 though and WordPress 3.4.

  22. soffx
    Member
    Posted 2 years ago #

    I also have the same issue
    I'm on a MAC. I have tried it on Safara and Chrome. WP 3.4, Gravity Forms Version 1.6.1, GF SF Add-on Version 1.1.3. I have also tried it on my VMWARE Windows Explorer and it has the same issue. The Advanced Tab does not show the SF option however in the Salesforce settings I can put in the Saleforce ID and it ticks it.

    Please could we have a resolution. I really need this functionality and I don't want to build it from scratch if it can be helped. If anyone knows any other plugin that can do the same thing (I've tried WordPress-to-Lead and it has no drop-down menus) please mention it. These are the solutions that I have come up with:
    http://www.jackreichert.com/2010/08/11/howto-salesforce-multiple-web-to-lead-forms-wordpress/

    and on another thread

    http://wordpress.org/support/topic/plugin-wordpress-to-lead-for-salesforce-crm-adding-drop-down-menu?replies=4#post-3018639

    Thanks guys!

    Soffx

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic